summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-08 14:32:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-08 14:32:20 +0000
commita6c9f1f60ca7e58ce0586727e676f04ce2006ed0 (patch)
treee2a8aa03c5b55a5c54a0a3d9385e5bd0baa1ec4b /dev-python/subvertpy
parentstable x86, bug 302437 (diff)
downloadgentoo-2-a6c9f1f60ca7e58ce0586727e676f04ce2006ed0.tar.gz
gentoo-2-a6c9f1f60ca7e58ce0586727e676f04ce2006ed0.tar.bz2
gentoo-2-a6c9f1f60ca7e58ce0586727e676f04ce2006ed0.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 15325-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/ChangeLog6
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.2.ebuild21
2 files changed, 23 insertions, 4 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index 8031e9eb09b4..95d20c5cd6fa 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.10 2010/01/13 06:36:25 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.11 2010/02/08 14:32:20 arfrever Exp $
+
+ 08 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ subvertpy-0.7.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
12 Jan 2010; <hwoarang@gentoo.org> subvertpy-0.7.1.ebuild:
Stable on amd64 wrt bug #299559
diff --git a/dev-python/subvertpy/subvertpy-0.7.2.ebuild b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
index 7d2bf3737a64..66cbac18ff65 100644
--- a/dev-python/subvertpy/subvertpy-0.7.2.ebuild
+++ b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.1 2010/01/04 08:12:40 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.2 2010/02/08 14:32:20 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Alternative Python bindings for Subversion."
-HOMEPAGE="http://samba.org/~jelmer/subvertpy/"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 LGPL-3 )"
@@ -19,5 +21,18 @@ RDEPEND=">=dev-util/subversion-1.4
!<dev-util/bzr-svn-0.5.0_rc2"
DEPEND="${RDEPEND}
test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
DOCS="NEWS AUTHORS"
+
+src_test() {
+ testing() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
+ done
+
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests
+ }
+ python_execute_function testing
+}