summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 19:06:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 19:06:05 +0000
commitafa9a2be7446e1b6e6620e4c2633428b5469eabd (patch)
tree11d6b345cf8db0fdbf100129b3ba0c626e85660c /dev-python/subvertpy
parentVersion bump (diff)
downloadgentoo-2-afa9a2be7446e1b6e6620e4c2633428b5469eabd.tar.gz
gentoo-2-afa9a2be7446e1b6e6620e4c2633428b5469eabd.tar.bz2
gentoo-2-afa9a2be7446e1b6e6620e4c2633428b5469eabd.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/ChangeLog8
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.3.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index 505fc9d4d2ea..0cdc250ee114 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.16 2010/07/21 11:42:29 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.17 2010/07/27 19:06:05 arfrever Exp $
+
+*subvertpy-0.7.3.1 (27 Jul 2010)
+
+ 27 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +subvertpy-0.7.3.1.ebuild:
+ Version bump.
*subvertpy-0.7.3 (21 Jul 2010)
diff --git a/dev-python/subvertpy/subvertpy-0.7.3.1.ebuild b/dev-python/subvertpy/subvertpy-0.7.3.1.ebuild
new file mode 100644
index 000000000000..378a12822ba7
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.7.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.3.1.ebuild,v 1.1 2010/07/27 19:06:05 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4
+ !<dev-util/bzr-svn-0.5.0_rc2"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}