summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-14 06:01:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-14 06:01:50 +0000
commit8560dade33814de85910238cda534684c0386660 (patch)
tree7991153cdef2391015fff4b793a57b3d89c0d2eb /dev-python/testresources/testresources-0.2.7-r1.ebuild
parentBump (diff)
downloadgentoo-2-8560dade33814de85910238cda534684c0386660.tar.gz
gentoo-2-8560dade33814de85910238cda534684c0386660.tar.bz2
gentoo-2-8560dade33814de85910238cda534684c0386660.zip
metadata; add python herd, revbump; add py3.3 support
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testresources/testresources-0.2.7-r1.ebuild')
-rw-r--r--dev-python/testresources/testresources-0.2.7-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/testresources/testresources-0.2.7-r1.ebuild b/dev-python/testresources/testresources-0.2.7-r1.ebuild
new file mode 100644
index 000000000000..e5b3acc5ab04
--- /dev/null
+++ b/dev-python/testresources/testresources-0.2.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7-r1.ebuild,v 1.1 2014/01/14 06:01:50 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testresources, a pyunit extension for managing expensive test resources."
+HOMEPAGE="https://launchpad.net/testresources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}