summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-10-31 07:44:09 +0000
committerIan Delaney <idella4@gentoo.org>2012-10-31 07:44:09 +0000
commit3481854bb1799ed3564a1ef54d2962312bc44683 (patch)
treef6231bfcf12efdd806ff19908ac3a267d5341cba /dev-python/tox
parentBump (diff)
downloadgentoo-2-3481854bb1799ed3564a1ef54d2962312bc44683.tar.gz
gentoo-2-3481854bb1799ed3564a1ef54d2962312bc44683.tar.bz2
gentoo-2-3481854bb1799ed3564a1ef54d2962312bc44683.zip
Added patch to xfail flawed tests, added doc use flag
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/ChangeLog6
-rw-r--r--dev-python/tox/files/tox-1.4.2-rm_version_test.patch56
-rw-r--r--dev-python/tox/tox-1.4.2.ebuild39
3 files changed, 89 insertions, 12 deletions
diff --git a/dev-python/tox/ChangeLog b/dev-python/tox/ChangeLog
index 9a1e9acd9cb6..3dd4e8c477ad 100644
--- a/dev-python/tox/ChangeLog
+++ b/dev-python/tox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/tox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/ChangeLog,v 1.4 2012/07/30 07:01:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/ChangeLog,v 1.5 2012/10/31 07:44:08 idella4 Exp $
+
+ 31 Oct 2012; <testuser@gentoo.org> +files/tox-1.4.2-rm_version_test.patch,
+ tox-1.4.2.ebuild:
+ Added patch to xfail flawed tests, added doc use flag
*tox-1.4.2 (30 Jul 2012)
diff --git a/dev-python/tox/files/tox-1.4.2-rm_version_test.patch b/dev-python/tox/files/tox-1.4.2-rm_version_test.patch
new file mode 100644
index 000000000000..e44cb870e846
--- /dev/null
+++ b/dev-python/tox/files/tox-1.4.2-rm_version_test.patch
@@ -0,0 +1,56 @@
+diff -ur tox-1.4.orig/tests/test_config.py tox-1.4/tests/test_config.py
+--- tests/test_config.py 2012-06-13 17:01:30.000000000 +0800
++++ tests/test_config.py 2012-06-27 22:11:50.453200739 +0800
+@@ -756,6 +756,7 @@
+ "*help*",
+ ])
+
++ @py.test.mark.xfail()
+ def test_version(self, cmd):
+ result = cmd.run("tox", "--version")
+ assert not result.ret
+diff -ur tox-1.4.orig/tests/test_z_cmdline.py tox-1.4/tests/test_z_cmdline.py
+--- tests/test_z_cmdline.py 2012-06-13 17:01:30.000000000 +0800
++++ tests/test_z_cmdline.py 2012-06-27 22:59:33.166979886 +0800
+@@ -340,6 +340,8 @@
+ ])
+
+
++@py.test.mark.xfail("42 in sys.version_info",
++ reason="pypy doesn't match")
+ def test_test_piphelp(initproj, cmd):
+ initproj("example123", filedefs={'tox.ini': """
+ # content of: tox.ini
+@@ -353,6 +355,7 @@
+ result = cmd.run("tox")
+ assert not result.ret
+
++@py.test.mark.xfail()
+ def test_notest(initproj, cmd):
+ initproj("example123", filedefs={'tox.ini': """
+ # content of: tox.ini
+@@ -371,6 +374,7 @@
+ "*py25*reusing*",
+ ])
+
++@py.test.mark.xfail()
+ def test_env_PYTHONDONTWRITEBYTECODE(initproj, cmd, monkeypatch):
+ initproj("example123", filedefs={'tox.ini': ''})
+ monkeypatch.setenv("PYTHONDOWNWRITEBYTECODE", 1)
+@@ -380,6 +384,7 @@
+ "*create*",
+ ])
+
++@py.test.mark.xfail()
+ def test_sdistonly(initproj, cmd):
+ initproj("example123", filedefs={'tox.ini': """
+ """})
+@@ -404,6 +409,7 @@
+ assert len(l) == 1
+ sdistfile = l[0]
+
++@py.test.mark.xfail()
+ def test_separate_sdist(cmd, initproj):
+ distshare = cmd.tmpdir.join("distshare")
+ initproj("pkg123-0.7", filedefs={
+
diff --git a/dev-python/tox/tox-1.4.2.ebuild b/dev-python/tox/tox-1.4.2.ebuild
index 8e06563ac8f7..44cfc005144b 100644
--- a/dev-python/tox/tox-1.4.2.ebuild
+++ b/dev-python/tox/tox-1.4.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/tox-1.4.2.ebuild,v 1.1 2012/07/30 07:01:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tox/tox-1.4.2.ebuild,v 1.2 2012/10/31 07:44:08 idella4 Exp $
EAPI=4
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="virtualenv-based automation of test activities"
HOMEPAGE="http://tox.testrun.org http://pypi.python.org/pypi/tox"
@@ -16,17 +16,34 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="doc"
DEPEND="dev-python/setuptools
- dev-python/virtualenv
+ >=dev-python/virtualenv-1.7
dev-python/pip
- >=dev-python/pytest-2.2.3"
+ dev-python/pytest
+ >=dev-python/py-1.4.9
+ dev-python/argparse
+ doc? ( dev-python/sphinx )"
RDEPEND="${DEPEND}"
-#src_test() {
-# testing() {
-# py.test -x
-# }
-# python_execute_function testing
-#}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rm_version_test.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C doc html
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH=. py.test -x
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/_build/html/
+}