summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-08 05:33:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-08 05:33:41 +0000
commit4399c9394d42e3d3b1310c3ec11925741893a604 (patch)
tree93ea484fd148af086c267d87878d2952c14bb6a1 /dev-python/tpg
parentBump (diff)
downloadgentoo-2-4399c9394d42e3d3b1310c3ec11925741893a604.tar.gz
gentoo-2-4399c9394d42e3d3b1310c3ec11925741893a604.tar.bz2
gentoo-2-4399c9394d42e3d3b1310c3ec11925741893a604.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/tpg')
-rw-r--r--dev-python/tpg/ChangeLog10
-rw-r--r--dev-python/tpg/tpg-3.2.2.ebuild47
2 files changed, 54 insertions, 3 deletions
diff --git a/dev-python/tpg/ChangeLog b/dev-python/tpg/ChangeLog
index cf21e48b7bb7..b44d892e28d9 100644
--- a/dev-python/tpg/ChangeLog
+++ b/dev-python/tpg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tpg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/ChangeLog,v 1.17 2012/06/06 08:06:46 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/ChangeLog,v 1.18 2014/01/08 05:33:41 patrick Exp $
+
+*tpg-3.2.2 (08 Jan 2014)
+
+ 08 Jan 2014; Patrick Lauer <patrick@gentoo.org> +tpg-3.2.2.ebuild:
+ Bump
*tpg-3.2.1 (06 Jun 2012)
@@ -73,4 +78,3 @@
02 May 2004; Bryan Østergaard <kloeri@gentoo.org> +metadata.xml,
+tpg-3.0.2.ebuild:
Initial import, bug #48538.
-
diff --git a/dev-python/tpg/tpg-3.2.2.ebuild b/dev-python/tpg/tpg-3.2.2.ebuild
new file mode 100644
index 000000000000..d2f3761430a7
--- /dev/null
+++ b/dev-python/tpg/tpg-3.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.2.2.ebuild,v 1.1 2014/01/08 05:33:41 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_TESTS_RESTRICTED_ABIS="2.5 2.6"
+
+inherit distutils
+
+MY_P="TPG-${PV}"
+
+DESCRIPTION="Toy Parser Generator for Python"
+HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
+SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="THANKS"
+PYTHON_MODNAME="tpg.py"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" tpg_tests.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/tpg.pdf || die "dodoc failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "doins failed"
+ fi
+}