summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-08 23:30:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-08 23:30:39 +0000
commit98f018192f44f7de18935b793158ca89c187fa76 (patch)
tree538a13b1202966efe5294a41d54c847035cfb66e /dev-python/twisted
parentBump to 2.24.1. (diff)
downloadgentoo-2-98f018192f44f7de18935b793158ca89c187fa76.tar.gz
gentoo-2-98f018192f44f7de18935b793158ca89c187fa76.tar.bz2
gentoo-2-98f018192f44f7de18935b793158ca89c187fa76.zip
Readding 1.2.0
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog5
-rw-r--r--dev-python/twisted/twisted-1.2.0.ebuild34
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 11ae93fad737..5085537125ec 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.102 2009/01/08 23:25:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.103 2009/01/08 23:30:39 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> +twisted-1.2.0.ebuild:
+ Undoing breakage
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> +twisted-1.3.0.ebuild:
Readding 1.3.0. Ooopsie ...
diff --git a/dev-python/twisted/twisted-1.2.0.ebuild b/dev-python/twisted/twisted-1.2.0.ebuild
new file mode 100644
index 000000000000..ad85a63bc225
--- /dev/null
+++ b/dev-python/twisted/twisted-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.0.ebuild,v 1.17 2009/01/08 23:30:39 patrick Exp $
+
+inherit distutils
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc alpha"
+IUSE="gtk doc"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/pycrypto-1.9_alpha6
+ dev-python/pyserial
+ dev-python/pyopenssl
+ gtk? ( >=dev-python/pygtk-1.99 )
+ doc? ( =dev-python/twisted-docs-${PV} )"
+
+S="${WORKDIR}/Twisted-${PV}"
+
+src_install() {
+ distutils_src_install
+
+ # use gtk2 if they so wish
+ if use gtk; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i '${D}/usr/bin/manhole'
+ fi
+}