summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-03-31 08:04:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-03-31 08:04:28 +0000
commit340b891875f03e8eb499b18d6e0e4fa3dc362662 (patch)
treedcf72bfc21825393ef9c25e3596f4825570124f7 /dev-python/virtualenvwrapper
parentUpdate to EAPI 5. Remove empty variable assignments. (diff)
downloadgentoo-2-340b891875f03e8eb499b18d6e0e4fa3dc362662.tar.gz
gentoo-2-340b891875f03e8eb499b18d6e0e4fa3dc362662.tar.bz2
gentoo-2-340b891875f03e8eb499b18d6e0e4fa3dc362662.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/virtualenvwrapper')
-rw-r--r--dev-python/virtualenvwrapper/ChangeLog9
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.2.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/virtualenvwrapper/ChangeLog b/dev-python/virtualenvwrapper/ChangeLog
index 73baa7cfd2a2..ca0eca1c1b35 100644
--- a/dev-python/virtualenvwrapper/ChangeLog
+++ b/dev-python/virtualenvwrapper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/virtualenvwrapper
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.13 2013/08/10 12:54:30 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.14 2014/03/31 08:04:28 patrick Exp $
+
+*virtualenvwrapper-4.2 (31 Mar 2014)
+
+ 31 Mar 2014; Patrick Lauer <patrick@gentoo.org> +virtualenvwrapper-4.2.ebuild:
+ Bump
*virtualenvwrapper-4.1.1 (10 Aug 2013)
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.2.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.2.ebuild
new file mode 100644
index 000000000000..f1fb9c6557e9
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/virtualenvwrapper-4.2.ebuild,v 1.1 2014/03/31 08:04:28 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6 3:3.1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython 2.7-pypy-*"
+
+inherit distutils python
+
+DESCRIPTION="virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="http://www.doughellmann.com/projects/virtualenvwrapper http://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT=test
+
+RDEPEND="dev-python/virtualenv
+ dev-python/stevedore
+ dev-python/virtualenv-clone"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/tox )"
+
+src_prepare() {
+ sed -e 's:-o shwordsplit::' -i tests/run_tests || die
+}
+
+src_test() {
+ testing() {
+ PYTHON_MAJOR="$(python_get_version --major)"
+ PYTHON_MINOR="$(python_get_version --minor)"
+ cp "${FILESDIR}/tox.ini" .
+ export TMPDIR=${T}
+ tox -e py${PYTHON_MAJOR}${PYTHON_MINOR} tests/test_cp.sh
+ }
+ python_execute_function testing
+}