summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-25 15:28:35 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-25 15:28:35 +0000
commit1f5c5ef8b9ac70ef590206d927bd025a9842491f (patch)
tree541dfe9025b80a0694f4ab9a9e1c0c9eac400965 /dev-python/webob
parentupdating routes for eapi5 support (diff)
downloadgentoo-2-1f5c5ef8b9ac70ef590206d927bd025a9842491f.tar.gz
gentoo-2-1f5c5ef8b9ac70ef590206d927bd025a9842491f.tar.bz2
gentoo-2-1f5c5ef8b9ac70ef590206d927bd025a9842491f.zip
upgrade dev-python/webob-1.0.8 to -r1 for distutils-r1 / eapi5 support
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog7
-rw-r--r--dev-python/webob/webob-1.0.8-r1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 888a0478d665..309aed234709 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.62 2013/02/15 18:58:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.63 2013/03/25 15:28:35 prometheanfire Exp $
+
+*webob-1.0.8-r1 (25 Mar 2013)
+
+ 25 Mar 2013; Matthew Thode <prometheanfire@gentoo.org> +webob-1.0.8-r1.ebuild:
+ upgrade dev-python/webob-1.0.8 to -r1 for distutils-r1 / eapi5 support
*webob-1.2.3-r1 (15 Feb 2013)
diff --git a/dev-python/webob/webob-1.0.8-r1.ebuild b/dev-python/webob/webob-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..f068e892da0c
--- /dev/null
+++ b/dev-python/webob/webob-1.0.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8-r1.ebuild,v 1.1 2013/03/25 15:28:35 prometheanfire Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils-r1_python_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_python_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}