summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-12-20 14:29:18 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-12-20 14:29:18 +0000
commit4c248b18e4cb7136ebed47c8f178edd9e8eeaa81 (patch)
tree11a9b82bd294e0892efcc88588c75a55051b2b19 /dev-python/webpy/webpy-0.22.ebuild
parentNew release. Fixes security issues, bug #199958. Thank Robert Buchholz <rbu A... (diff)
downloadgentoo-2-4c248b18e4cb7136ebed47c8f178edd9e8eeaa81.tar.gz
gentoo-2-4c248b18e4cb7136ebed47c8f178edd9e8eeaa81.tar.bz2
gentoo-2-4c248b18e4cb7136ebed47c8f178edd9e8eeaa81.zip
Added webpy-0.22 to the tree (#196487).
Diffstat (limited to 'dev-python/webpy/webpy-0.22.ebuild')
-rw-r--r--dev-python/webpy/webpy-0.22.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/webpy/webpy-0.22.ebuild b/dev-python/webpy/webpy-0.22.ebuild
new file mode 100644
index 000000000000..9145d4eeefa9
--- /dev/null
+++ b/dev-python/webpy/webpy-0.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.22.ebuild,v 1.1 2007/12/20 14:29:18 wrobel Exp $
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for python"
+HOMEPAGE="http://www.webpy.org"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+PYTHON_MODNAME="web"
+
+src_test() {
+ TESTS="db template net http utils"
+
+ cd "${S}"
+
+ for TEST in ${TESTS}
+ do
+ ${python} web/${TEST}.py || die "Doctest in web/${TEST}.py failed!"
+ done
+}