summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-07 16:25:19 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-07 16:25:19 +0000
commit78df883e038e684b816e7ea9fe7b5e5af2f84fca (patch)
treecab5263753ad267763edc0ff6b2c1ec51f500fe6 /dev-python/wehjit
parentRemove old (diff)
downloadgentoo-2-78df883e038e684b816e7ea9fe7b5e5af2f84fca.tar.gz
gentoo-2-78df883e038e684b816e7ea9fe7b5e5af2f84fca.tar.bz2
gentoo-2-78df883e038e684b816e7ea9fe7b5e5af2f84fca.zip
patch added skipping invalid test(s), python2.5 test restricted, test phases upgraded, fixes Bug #429812
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wehjit')
-rw-r--r--dev-python/wehjit/ChangeLog8
-rw-r--r--dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch23
-rw-r--r--dev-python/wehjit/wehjit-0.2.2.ebuild24
3 files changed, 49 insertions, 6 deletions
diff --git a/dev-python/wehjit/ChangeLog b/dev-python/wehjit/ChangeLog
index 42a3f89a0c76..3dc6e5ebf6b2 100644
--- a/dev-python/wehjit/ChangeLog
+++ b/dev-python/wehjit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wehjit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/ChangeLog,v 1.3 2012/02/23 04:31:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/ChangeLog,v 1.4 2012/11/07 16:25:18 idella4 Exp $
+
+ 08 Nov 2012; Ian Delaney <idella4@gentoo.org>
+ +files/wehjit-0.2.2-SkipTest.patch, wehjit-0.2.2.ebuild:
+ patch added skipping invalid test(s), python2.5 test restricted, test phases
+ upgraded, fixes Bug #429812
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> wehjit-0.2.2.ebuild:
Restricting jython
@@ -13,4 +18,3 @@
30 Oct 2011; Maxim Koltsov <maksbotan@gentoo.org> +wehjit-0.2.2.ebuild,
+metadata.xml:
Add dev-python/wehjit-0.2.2, thanks to slepnoga. Bug #305887
-
diff --git a/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
new file mode 100644
index 000000000000..057d70747e74
--- /dev/null
+++ b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
@@ -0,0 +1,23 @@
+diff -ur wehjit-0.2.2.orig/wehjit/collection.py wehjit-0.2.2/wehjit/collection.py
+--- wehjit/collection.py 2010-02-11 16:26:14.000000000 +0800
++++ wehjit/collection.py 2012-11-08 14:24:40.326482713 +0800
+@@ -22,6 +22,11 @@
+ Collect widget plugins together in a `Collection`.
+ """
+
++import sys
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
+ import inspect
+ import os
+ from os import path
+@@ -130,6 +135,7 @@
+ """
+ return name in self.__plugins
+
++ @unittest.skip("Plugin not in gentoo")
+ def __getitem__(self, name):
+ """
+ Return the plugin named ``name``.
diff --git a/dev-python/wehjit/wehjit-0.2.2.ebuild b/dev-python/wehjit/wehjit-0.2.2.ebuild
index 09f424048405..83677d09feb7 100644
--- a/dev-python/wehjit/wehjit-0.2.2.ebuild
+++ b/dev-python/wehjit/wehjit-0.2.2.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/wehjit-0.2.2.ebuild,v 1.2 2012/02/23 04:31:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/wehjit-0.2.2.ebuild,v 1.3 2012/11/07 16:25:18 idella4 Exp $
EAPI=3
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
+#DISTUTILS_SRC_TEST="nosetests" # for now can't be used in src_test
+PYTHON_TESTS_RESTRICTED_ABIS="2.5"
+inherit distutils eutils
DESCRIPTION="A Python web-widget library"
HOMEPAGE="http://jderose.fedorapeople.org/wehjit"
@@ -29,3 +29,19 @@ DEPEND="${RDEPEND}"
DOCS="README TODO NEWS AUTHORS"
python_enable_pyc
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-SkipTest.patch
+}
+
+src_test() {
+ testing() {
+ if [[ "${PYTHON_ABI:2:1}" == '6' ]]; then
+ nosetests -I test_app* -e=*getitem
+ else
+ nosetests
+ fi
+ }
+ python_execute_function testing
+}