summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-24 16:57:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-24 16:57:21 +0000
commitf32997409ac8fbc2864990b17e4e353cab567fc3 (patch)
treea233aa3a4e402a0fdeb444e5c063c44e46d3622c /dev-python/werkzeug
parentBump to 8.2.0, fixes #255415 (diff)
downloadgentoo-2-f32997409ac8fbc2864990b17e4e353cab567fc3.tar.gz
gentoo-2-f32997409ac8fbc2864990b17e4e353cab567fc3.tar.bz2
gentoo-2-f32997409ac8fbc2864990b17e4e353cab567fc3.zip
Bump to 0.4.1, fixes #255443
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog7
-rw-r--r--dev-python/werkzeug/werkzeug-0.4.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index fdcd95fc1e1c..424b27e98a93 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.6 2009/01/08 21:26:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.7 2009/01/24 16:57:21 patrick Exp $
+
+*werkzeug-0.4.1 (24 Jan 2009)
+
+ 24 Jan 2009; Patrick Lauer <patrick@gentoo.org> +werkzeug-0.4.1.ebuild:
+ Bump to 0.4.1, fixes #255443
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -werkzeug-0.3.1-r1.ebuild:
Removing old
diff --git a/dev-python/werkzeug/werkzeug-0.4.1.ebuild b/dev-python/werkzeug/werkzeug-0.4.1.ebuild
new file mode 100644
index 000000000000..cdc0458658ee
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.4.1.ebuild,v 1.1 2009/01/24 16:57:21 patrick Exp $
+
+NEED_PYTHON="2.4"
+
+inherit distutils
+
+MY_P="Werkzeug-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/"
+SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=">=dev-python/setuptools-0.6_rc5
+ test? ( dev-python/py
+ dev-python/lxml
+ dev-python/simplejson )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ # Rearraning the docs
+ rm -rf "${D}/usr/docs"
+ dodoc docs/src/*
+ dohtml docs/html/*
+}
+
+src_test() {
+ distutils_python_version
+ # path gets set correctly in conftest.py
+ cd tests
+ py.test || die "tests failed"
+}