summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-26 18:32:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-26 18:32:09 +0000
commit9676cae0e6d4d13d72e3d98d232483c48d34cb25 (patch)
treea40a00bc9f4032b3066e63513e13e8fd922e116e /dev-python/whoosh
parentx86 stable wrt bug #503310 (diff)
downloadgentoo-2-9676cae0e6d4d13d72e3d98d232483c48d34cb25.tar.gz
gentoo-2-9676cae0e6d4d13d72e3d98d232483c48d34cb25.tar.bz2
gentoo-2-9676cae0e6d4d13d72e3d98d232483c48d34cb25.zip
Version bump, bug #505830
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/ChangeLog9
-rw-r--r--dev-python/whoosh/whoosh-2.5.7.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/whoosh/ChangeLog b/dev-python/whoosh/ChangeLog
index eedb1a96196b..37fc4cf97ed4 100644
--- a/dev-python/whoosh/ChangeLog
+++ b/dev-python/whoosh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/whoosh
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.17 2013/09/23 02:53:04 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.18 2014/03/26 18:32:09 blueness Exp $
+
+*whoosh-2.5.7 (26 Mar 2014)
+
+ 26 Mar 2014; Anthony G. Basile <blueness@gentoo.org> +whoosh-2.5.7.ebuild:
+ Version bump, bug #505830
*whoosh-2.5.4 (23 Sep 2013)
diff --git a/dev-python/whoosh/whoosh-2.5.7.ebuild b/dev-python/whoosh/whoosh-2.5.7.ebuild
new file mode 100644
index 000000000000..69c8466312a6
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.5.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/whoosh-2.5.7.ebuild,v 1.1 2014/03/26 18:32:09 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+MY_PN="Whoosh"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
+SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( README.txt )
+ use doc && local HTML_DOCS=( docs/build/html/_sources/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}