summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-24 04:26:19 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-24 04:26:19 +0000
commit75dc8d69f6954e51fc2f0029043226ca28693b7e (patch)
tree166b4dece70407c03c8ca5fab5f71242997e7041 /dev-python/ws4py
parentre-keyword ~arm to -3.2, tested on armv7, cubieboard2, qa correction to deps.... (diff)
downloadgentoo-2-75dc8d69f6954e51fc2f0029043226ca28693b7e.tar.gz
gentoo-2-75dc8d69f6954e51fc2f0029043226ca28693b7e.tar.bz2
gentoo-2-75dc8d69f6954e51fc2f0029043226ca28693b7e.zip
bump; drop py2.6 add py3 support, add previously known optional deps, update test phase to one that (works for this version)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ChangeLog8
-rw-r--r--dev-python/ws4py/ws4py-0.3.4.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index 7e967fcf494f..f59d72b1a810 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ws4py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.12 2014/05/03 08:12:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.13 2014/05/24 04:26:19 idella4 Exp $
+
+*ws4py-0.3.4 (24 May 2014)
+
+ 24 May 2014; Ian Delaney <idella4@gentoo.org> +ws4py-0.3.4.ebuild:
+ bump; drop py2.6 add py3 support, add previously known optional deps, update
+ test phase to one that (works for this version)
*ws4py-0.3.3 (03 May 2014)
diff --git a/dev-python/ws4py/ws4py-0.3.4.ebuild b/dev-python/ws4py/ws4py-0.3.4.ebuild
new file mode 100644
index 000000000000..95103d69cb7f
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.3.4.ebuild,v 1.1 2014/05/24 04:26:19 idella4 Exp $
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ... so why not???
+# pypy is viable but better with a cutdown set of deps
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+# doc build requires sphinxcontrib ext packages absent from portage
+
+RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ dev-python/gevent[$(python_gen_usedep python2_7)]
+ >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
+ server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # testsuite displays an issue with mock under py3 but is non fatal
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}