summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-17 03:49:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-17 03:49:18 +0000
commit0e9ec6abd1ad805a9ab5b2d19a4f324bf3dc79fc (patch)
treec8c05583bea38ebfde1232c663b9c8e207fafc06 /dev-python/wtforms
parentBump (diff)
downloadgentoo-2-0e9ec6abd1ad805a9ab5b2d19a4f324bf3dc79fc.tar.gz
gentoo-2-0e9ec6abd1ad805a9ab5b2d19a4f324bf3dc79fc.tar.bz2
gentoo-2-0e9ec6abd1ad805a9ab5b2d19a4f324bf3dc79fc.zip
Bump
(Portage version: 2.2.6/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-1.0.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 185b2dd388f2..ac83f693a2ec 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.33 2013/09/05 18:46:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.34 2013/09/17 03:49:18 patrick Exp $
+
+*wtforms-1.0.5 (17 Sep 2013)
+
+ 17 Sep 2013; Patrick Lauer <patrick@gentoo.org> +wtforms-1.0.5.ebuild:
+ Bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> wtforms-1.0.3-r1.ebuild,
wtforms-1.0.4.ebuild:
diff --git a/dev-python/wtforms/wtforms-1.0.5.ebuild b/dev-python/wtforms/wtforms-1.0.5.ebuild
new file mode 100644
index 000000000000..77b3c76e8be0
--- /dev/null
+++ b/dev-python/wtforms/wtforms-1.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.5.ebuild,v 1.1 2013/09/17 03:49:18 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}