summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-05-29 12:54:20 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-05-29 12:54:20 +0000
commit19d0c1c5940681e74eac9f9f3dceedff0f92159e (patch)
treef1340f7701fe6492ed61e277604a19ded14022d6 /dev-python/wtforms
parentVersion bump (diff)
downloadgentoo-2-19d0c1c5940681e74eac9f9f3dceedff0f92159e.tar.gz
gentoo-2-19d0c1c5940681e74eac9f9f3dceedff0f92159e.tar.bz2
gentoo-2-19d0c1c5940681e74eac9f9f3dceedff0f92159e.zip
Add python3 compat for wtforms-2.0 (bug 485018)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog5
-rw-r--r--dev-python/wtforms/wtforms-2.0.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index f801cf59ab8e..b09e12591188 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.37 2014/05/29 12:51:03 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.38 2014/05/29 12:54:20 djc Exp $
+
+ 29 May 2014; Dirkjan Ochtman <djc@gentoo.org> wtforms-2.0.ebuild:
+ Add python3 compat for wtforms-2.0 (bug 485018)
29 May 2014; Dirkjan Ochtman <djc@gentoo.org> -wtforms-0.6.3.ebuild,
-wtforms-1.0.1.ebuild, -wtforms-1.0.2.ebuild, -wtforms-1.0.3-r1.ebuild,
diff --git a/dev-python/wtforms/wtforms-2.0.ebuild b/dev-python/wtforms/wtforms-2.0.ebuild
index b7d1dd9e6f52..8905f8153150 100644
--- a/dev-python/wtforms/wtforms-2.0.ebuild
+++ b/dev-python/wtforms/wtforms-2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-2.0.ebuild,v 1.1 2014/05/26 08:15:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-2.0.ebuild,v 1.2 2014/05/29 12:54:20 djc Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
inherit distutils-r1
@@ -22,6 +22,7 @@ IUSE="doc"
S="${WORKDIR}/${MY_P}"
DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
RDEPEND=""
@@ -31,12 +32,16 @@ python_compile_all() {
if use doc; then
einfo "Generation of documentation"
cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
+ PYTHONPATH=".." emake html
fi
}
+python_test() {
+ esetup.py test || die "Tests failed for ${EPYTHON}"
+}
+
python_install_all() {
if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ dohtml -r docs/_build/html/*
fi
}