summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-16 08:46:43 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-16 08:46:43 +0000
commit73167ee039ca83a99215a4403a865d1c957b7383 (patch)
tree3a63b6f7726a775a573f9827f41336628a211ebf /dev-python/wtforms
parentsys-kernel/aufs-sources: Bump to genpatches 3.8-5 (diff)
downloadgentoo-2-73167ee039ca83a99215a4403a865d1c957b7383.tar.gz
gentoo-2-73167ee039ca83a99215a4403a865d1c957b7383.tar.bz2
gentoo-2-73167ee039ca83a99215a4403a865d1c957b7383.zip
revbump migration -r1
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-1.0.3-r1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 23d4bd616959..5aa63d840231 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.24 2013/01/28 09:49:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.25 2013/03/16 08:46:43 idella4 Exp $
+
+*wtforms-1.0.3-r1 (16 Mar 2013)
+
+ 16 Mar 2013; Ian Delaney <idella4@gentoo.org> +wtforms-1.0.3-r1.ebuild:
+ revbump migration -r1
*wtforms-1.0.3 (28 Jan 2013)
diff --git a/dev-python/wtforms/wtforms-1.0.3-r1.ebuild b/dev-python/wtforms/wtforms-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..fd15f8f6a56a
--- /dev/null
+++ b/dev-python/wtforms/wtforms-1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.3-r1.ebuild,v 1.1 2013/03/16 08:46:43 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}