summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-03-21 01:56:37 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-03-21 01:56:37 +0000
commitf59803f2966264bcb8c5e11f5f84601240b9e5ca (patch)
tree01e9d6ec7ebe47bf6e95d569835eabe149bf8149 /dev-python/wxpython
parentPatched gnbd to compile also with kernel >= 2.6.20. (diff)
downloadgentoo-2-f59803f2966264bcb8c5e11f5f84601240b9e5ca.tar.gz
gentoo-2-f59803f2966264bcb8c5e11f5f84601240b9e5ca.tar.bz2
gentoo-2-f59803f2966264bcb8c5e11f5f84601240b9e5ca.zip
Move wxaddons module into version-specific directories to fix bug #213819.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild13
-rw-r--r--dev-python/wxpython/wxpython-2.8.7.1.ebuild13
3 files changed, 27 insertions, 5 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index bd7bf45fa85c..506c49bb93ee 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.86 2008/03/17 12:39:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.87 2008/03/21 01:56:37 dirtyepic Exp $
+
+ 21 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
+ wxpython-2.8.7.1.ebuild:
+ Move wxaddons module into version-specific directories to fix bug #213819.
17 Mar 2008; Peter Volkov <pva@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
wxpython-2.8.7.1.ebuild:
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index c90f51f8575c..ded082f890a5 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.12 2008/03/17 12:39:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.13 2008/03/21 01:56:37 dirtyepic Exp $
EAPI=1
@@ -87,9 +87,18 @@ src_install() {
--install-purelib ${site_pkgs} || die "setup.py install failed"
# Collision protection.
- for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
mv "${file}" "${file}-${SLOT}"
done
+
+ for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
+ if [[ -d ${dir} ]]; then
+ cp -R "${D}"/${site_pkgs}/wxaddons/ ${dir}
+ wxaddons_copied=1
+ fi
+ done
+
+ [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
}
pkg_postinst() {
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
index f85114a67fb5..2f9946fe57f2 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.9 2008/03/17 12:39:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.10 2008/03/21 01:56:37 dirtyepic Exp $
EAPI="1"
WX_GTK_VER="2.8"
@@ -76,9 +76,18 @@ src_install() {
--install-purelib ${site_pkgs} || die "setup.py install failed"
# Collision protection.
- for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
mv "${file}" "${file}-${SLOT}"
done
+
+ for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
+ if [[ -d ${dir} ]]; then
+ cp -R "${D}"/${site_pkgs}/wxaddons/ ${dir}
+ wxaddons_copied=1
+ fi
+ done
+
+ [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
}
pkg_postinst() {