summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-25 09:26:36 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-25 09:26:36 +0000
commitfc19e70dd0f64a1a1623f4797d39c93cc2859647 (patch)
tree4f3afb7c90bf65fa1c93c87cf13919d46418d260 /dev-python/xvfbwrapper
parentRevision bump adds upstream patch to respect CXXFLAGS, bug #508300. (diff)
downloadgentoo-2-fc19e70dd0f64a1a1623f4797d39c93cc2859647.tar.gz
gentoo-2-fc19e70dd0f64a1a1623f4797d39c93cc2859647.tar.bz2
gentoo-2-fc19e70dd0f64a1a1623f4797d39c93cc2859647.zip
bump; add py3.4 pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/xvfbwrapper')
-rw-r--r--dev-python/xvfbwrapper/ChangeLog10
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild6
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild29
3 files changed, 40 insertions, 5 deletions
diff --git a/dev-python/xvfbwrapper/ChangeLog b/dev-python/xvfbwrapper/ChangeLog
index 9ac0e285d6f4..b84764d8c461 100644
--- a/dev-python/xvfbwrapper/ChangeLog
+++ b/dev-python/xvfbwrapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/xvfbwrapper
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xvfbwrapper/ChangeLog,v 1.1 2013/05/31 04:17:24 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xvfbwrapper/ChangeLog,v 1.2 2014/05/25 09:26:36 idella4 Exp $
+
+*xvfbwrapper-0.2.4 (25 May 2014)
+
+ 25 May 2014; Ian Delaney <idella4@gentoo.org> +xvfbwrapper-0.2.4.ebuild,
+ xvfbwrapper-0.2.2.ebuild:
+ bump; add py3.4 pypy support
*xvfbwrapper-0.2.2 (31 May 2013)
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild
index 13990897274b..32f36dc3fb86 100644
--- a/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild,v 1.1 2013/05/31 04:17:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild,v 1.2 2014/05/25 09:26:36 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3} )
@@ -24,5 +24,5 @@ DEPEND="${RDEPEND}
python_test() {
unset DISPLAY
- "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+ "${PYTHON}" test_xvfb.py || die "Tests failed with ${EPYTHON}"
}
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild
new file mode 100644
index 000000000000..6cbfd4d4e2a0
--- /dev/null
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild
@@ -0,0 +1,29 @@
+
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild,v 1.1 2014/05/25 09:26:36 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
+HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper
+ http://pypi.python.org/pypi/xvfbwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-base/xorg-server[xvfb]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+# "${PYTHON}" test_xvfb.py || die "Tests failed with ${EPYTHON}"
+ "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}