summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-12 23:22:46 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-12 23:22:46 +0000
commit6df555042467f5a129dd5a719e551252dbf97314 (patch)
treee563ee9e77ffa9103ddc6e88e6f79bc5c0d9cedc /dev-python/zc-buildout
parentgames-engines/sarien is gone (diff)
downloadgentoo-2-6df555042467f5a129dd5a719e551252dbf97314.tar.gz
gentoo-2-6df555042467f5a129dd5a719e551252dbf97314.tar.bz2
gentoo-2-6df555042467f5a129dd5a719e551252dbf97314.zip
Move from net-zope/zc-buildout.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/zc-buildout')
-rw-r--r--dev-python/zc-buildout/ChangeLog10
-rw-r--r--dev-python/zc-buildout/metadata.xml23
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.2.4.ebuild34
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.2.5.ebuild34
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/zc-buildout/ChangeLog b/dev-python/zc-buildout/ChangeLog
new file mode 100644
index 000000000000..f06aeff3f0d3
--- /dev/null
+++ b/dev-python/zc-buildout/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/zc-buildout
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zc-buildout/ChangeLog,v 1.1 2014/12/12 23:22:46 mgorny Exp $
+
+*zc-buildout-2.2.4 (12 Dec 2014)
+*zc-buildout-2.2.5 (12 Dec 2014)
+
+ 12 Dec 2014; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +zc-buildout-2.2.4.ebuild, +zc-buildout-2.2.5.ebuild:
+ Move from net-zope/zc-buildout.
diff --git a/dev-python/zc-buildout/metadata.xml b/dev-python/zc-buildout/metadata.xml
new file mode 100644
index 000000000000..cca1f992b28e
--- /dev/null
+++ b/dev-python/zc-buildout/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ <name>Alfredo Tupone</name>
+ </maintainer>
+ <longdescription lang="en">Buildout is a system for managing development buildouts. While often identified as a Zope project,
+and indeed licensed under the ZPL by Zope creator Jim Fulton, buildout is useful for configurations
+beyond Zope, and even, in rare cases, a few that have nothing to do with Python.
+The Buildout project provides support for creating applications, especially Python applications. It
+provides tools for assembling applications from multiple parts, Python or otherwise. An application
+may actually contain multiple programs, processes, and configuration settings.
+The word .buildout. refers to a description of a set of parts and the software to create and assemble
+them. It is often used informally to refer to an installed system based on a buildout definition. For
+example, if we are creating an application named .Foo., then .the Foo buildout. is the collection of
+configuration and application-specific software that allows an instance of the application to be
+created. We may refer to such an instance of the application informally as .a Foo buildout..</longdescription>
+ <upstream>
+ <remote-id type="pypi">zc.buildout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zc-buildout/zc-buildout-2.2.4.ebuild b/dev-python/zc-buildout/zc-buildout-2.2.4.ebuild
new file mode 100644
index 000000000000..76e52ed16228
--- /dev/null
+++ b/dev-python/zc-buildout/zc-buildout-2.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zc-buildout/zc-buildout-2.2.4.ebuild,v 1.1 2014/12/12 23:22:46 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://pypi.python.org/pypi/zc.buildout"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/setuptools-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( README.rst doc/tutorial.txt )
+# Tests require zope packages absent from portage
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+ sed -e '/^ include_package_data/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/zc-buildout/zc-buildout-2.2.5.ebuild b/dev-python/zc-buildout/zc-buildout-2.2.5.ebuild
new file mode 100644
index 000000000000..a14618202677
--- /dev/null
+++ b/dev-python/zc-buildout/zc-buildout-2.2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zc-buildout/zc-buildout-2.2.5.ebuild,v 1.1 2014/12/12 23:22:46 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://pypi.python.org/pypi/zc.buildout"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( README.rst doc/tutorial.txt )
+# Tests require zope packages absent from portage
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+ sed -e '/^ include_package_data/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}