summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-05-12 06:03:08 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-05-12 06:03:08 +0000
commit051687ce2d93d2af6d8c32ac124f33ffbdb2c809 (patch)
tree5682e8b4ab0fcec9f30b5138cd8a9d074592f8e1 /dev-python
parentre-write of test phase after further testing and probing of the testsuite, mo... (diff)
downloadgentoo-2-051687ce2d93d2af6d8c32ac124f33ffbdb2c809.tar.gz
gentoo-2-051687ce2d93d2af6d8c32ac124f33ffbdb2c809.tar.bz2
gentoo-2-051687ce2d93d2af6d8c32ac124f33ffbdb2c809.zip
bup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hacking/ChangeLog7
-rw-r--r--dev-python/hacking/hacking-0.9.5.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/hacking/ChangeLog b/dev-python/hacking/ChangeLog
index 40bf41ff3546..6a67cd3145b5 100644
--- a/dev-python/hacking/ChangeLog
+++ b/dev-python/hacking/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hacking
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.16 2015/03/08 23:50:02 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.17 2015/05/12 06:03:08 prometheanfire Exp $
+
+*hacking-0.9.5 (12 May 2015)
+
+ 12 May 2015; Matthew Thode <prometheanfire@gentoo.org> +hacking-0.9.5.ebuild:
+ bup
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> hacking-0.10.1.ebuild,
hacking-0.8.1.ebuild, hacking-0.9.2.ebuild:
diff --git a/dev-python/hacking/hacking-0.9.5.ebuild b/dev-python/hacking/hacking-0.9.5.ebuild
new file mode 100644
index 000000000000..9d7956401e28
--- /dev/null
+++ b/dev-python/hacking/hacking-0.9.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.9.5.ebuild,v 1.1 2015/05/12 06:03:08 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack-dev/hacking"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="~dev-python/pep8-1.5.6[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ ${RDEPEND} )
+ doc? ( >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/oslo-sphinx[${PYTHON_USEDEP}]' python2_7 ) )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Prevent d'loading and correct ?typo to oslosphinx in conf.py
+ sed -e 's:intersphinx_mapping:#&:' \
+ -e 's:oslosphinx:oslo.sphinx:' \
+ -i doc/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
+}
+
+python_test() {
+ testr init || die "testr init died"
+ testr run || die "testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}