summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-17 07:19:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-17 07:19:13 +0000
commit05d20a291c8b5d7f3cc6c8555d80665df23cdb81 (patch)
tree28c5fe4845b8fa8a9f7e7f3d9417008b5d7e3f1e /dev-python
parentAdjust PyQt4 dependencies ( bug 272144 ) (diff)
downloadgentoo-2-05d20a291c8b5d7f3cc6c8555d80665df23cdb81.tar.gz
gentoo-2-05d20a291c8b5d7f3cc6c8555d80665df23cdb81.tar.bz2
gentoo-2-05d20a291c8b5d7f3cc6c8555d80665df23cdb81.zip
Revbump to fix PyQt4 use dependencies ( bug 272148 )
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pynotifier/ChangeLog10
-rw-r--r--dev-python/pynotifier/pynotifier-0.7.0-r1.ebuild27
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/pynotifier/ChangeLog b/dev-python/pynotifier/ChangeLog
index 01de92fc1624..d90f73bc0f38 100644
--- a/dev-python/pynotifier/ChangeLog
+++ b/dev-python/pynotifier/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pynotifier
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/ChangeLog,v 1.10 2008/05/01 09:26:44 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/ChangeLog,v 1.11 2009/07/17 07:19:13 hwoarang Exp $
+
+*pynotifier-0.7.0-r1 (17 Jul 2009)
+
+ 17 Jul 2009; Markos Chandras <hwoarang@gentoo.org>
+ +pynotifier-0.7.0-r1.ebuild:
+ Revbump to fix PyQt4 use dependencies ( bug 272148 )
01 May 2008; Tobias Scherbaum <dertobi123@gentoo.org>
pynotifier-0.7.0.ebuild:
diff --git a/dev-python/pynotifier/pynotifier-0.7.0-r1.ebuild b/dev-python/pynotifier/pynotifier-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..7c7fb7bb9d6c
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.7.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/pynotifier-0.7.0-r1.ebuild,v 1.1 2009/07/17 07:19:13 hwoarang Exp $
+
+EAPI="2"
+
+inherit distutils
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler."
+HOMEPAGE="http://www.bitkipper.net/"
+SRC_URI="http://www.bitkipper.net/bytes/debian/dists/unstable/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 gtk"
+
+DEPEND=""
+RDEPEND="dev-python/twisted
+ gtk? ( dev-python/pygobject )
+ qt4? ( dev-python/PyQt4[X] )"
+
+src_prepare() {
+ distutils_src_prepare
+ use qt4 || rm notifier/nf_qt.py
+ use gtk || rm notifier/nf_gtk.py
+}