summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 12:14:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 12:14:59 +0000
commit08087dcf5611be76922daa3544a07703abdda47e (patch)
tree3a86e24d777a382328eeef8288fbcb5c913f2f1c /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-08087dcf5611be76922daa3544a07703abdda47e.tar.gz
gentoo-2-08087dcf5611be76922daa3544a07703abdda47e.tar.bz2
gentoo-2-08087dcf5611be76922daa3544a07703abdda47e.zip
Version bump.
(Portage version: 15196-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apsw/ChangeLog10
-rw-r--r--dev-python/apsw/apsw-3.6.22.1.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-python/apsw/ChangeLog b/dev-python/apsw/ChangeLog
index 1d645fe52ba8..1865b49b29ad 100644
--- a/dev-python/apsw/ChangeLog
+++ b/dev-python/apsw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apsw
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.24 2009/12/28 22:38:10 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.25 2010/01/12 12:14:59 arfrever Exp $
+
+*apsw-3.6.22.1 (12 Jan 2010)
+
+ 12 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +apsw-3.6.22.1.ebuild:
+ Version bump.
28 Dec 2009; Markus Meier <maekke@gentoo.org> apsw-3.6.20.1.ebuild:
x86 stable, bug #296039
diff --git a/dev-python/apsw/apsw-3.6.22.1.ebuild b/dev-python/apsw/apsw-3.6.22.1.ebuild
new file mode 100644
index 000000000000..8a72a7cf1660
--- /dev/null
+++ b/dev-python/apsw/apsw-3.6.22.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.6.22.1.ebuild,v 1.1 2010/01/12 12:14:59 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils versionator
+
+MY_PV="$(replace_version_separator 3 -r)"
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="http://code.google.com/p/apsw/"
+SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.6.6.2"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+}
+
+src_compile() {
+ distutils_src_compile --omit=LOAD_EXTENSION
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/_sources/*
+ dohtml -r doc/*
+}