summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-12-28 22:32:10 +0000
committerMichael Weber <xmw@gentoo.org>2013-12-28 22:32:10 +0000
commit0e2845538e9e749951f700d18845eb1201fb0369 (patch)
tree660677337ac2ab027a412fd111f9e3037e11e2e0 /dev-python
parentdev-db/wxsqlite3: Fix pc file (diff)
downloadgentoo-2-0e2845538e9e749951f700d18845eb1201fb0369.tar.gz
gentoo-2-0e2845538e9e749951f700d18845eb1201fb0369.tar.bz2
gentoo-2-0e2845538e9e749951f700d18845eb1201fb0369.zip
Remove broken OS X fix, thanks Laurent Bachelier (bug 451416)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/netifaces/ChangeLog8
-rw-r--r--dev-python/netifaces/files/netifaces-0.8-remove-osx-fix.patch23
-rw-r--r--dev-python/netifaces/netifaces-0.8-r2.ebuild23
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/netifaces/ChangeLog b/dev-python/netifaces/ChangeLog
index 949321896e1c..4cf1ab6967cc 100644
--- a/dev-python/netifaces/ChangeLog
+++ b/dev-python/netifaces/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/netifaces
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/ChangeLog,v 1.13 2013/09/05 18:46:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/ChangeLog,v 1.14 2013/12/28 22:32:10 xmw Exp $
+
+*netifaces-0.8-r2 (28 Dec 2013)
+
+ 28 Dec 2013; Michael Weber <xmw@gentoo.org>
+ +files/netifaces-0.8-remove-osx-fix.patch, +netifaces-0.8-r2.ebuild:
+ Remove broken OS X fix, thanks Laurent Bachelier (bug 451416)
05 Sep 2013; Michał Górny <mgorny@gentoo.org> netifaces-0.8-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/netifaces/files/netifaces-0.8-remove-osx-fix.patch b/dev-python/netifaces/files/netifaces-0.8-remove-osx-fix.patch
new file mode 100644
index 000000000000..41aedaf02a67
--- /dev/null
+++ b/dev-python/netifaces/files/netifaces-0.8-remove-osx-fix.patch
@@ -0,0 +1,23 @@
+# HG changeset patch
+# User Laurent Bachelier <laurent@bachelier.name>
+# Date 1388257625 -3600
+# Node ID d89bc5823b639a13d299c7485fd81be89ef036a1
+# Parent aa1a71e0adf7129f99c087afa9416a37b527012b
+Remove support for broken operating systems
+
+diff -r aa1a71e0adf7 -r d89bc5823b63 setup.py
+--- a/setup.py Tue Jan 31 11:48:23 2012 +0000
++++ b/setup.py Sat Dec 28 20:07:05 2013 +0100
+@@ -9,12 +9,6 @@
+
+ __version__ = "0.8"
+
+-# Disable hard links, otherwise building distributions fails on OS X
+-try:
+- del os.link
+-except:
+- pass
+-
+ # On Windows, we need ws2_32 and iphlpapi
+ if getattr(sys, 'getwindowsversion', None):
+ libraries = ['ws2_32', 'iphlpapi']
diff --git a/dev-python/netifaces/netifaces-0.8-r2.ebuild b/dev-python/netifaces/netifaces-0.8-r2.ebuild
new file mode 100644
index 000000000000..a5b92d14dfd5
--- /dev/null
+++ b/dev-python/netifaces/netifaces-0.8-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/netifaces-0.8-r2.ebuild,v 1.1 2013/12/28 22:32:10 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Portable network interface information"
+HOMEPAGE="http://alastairs-place.net/netifaces/"
+SRC_URI="http://alastairs-place.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-remove-osx-fix.patch )