summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-17 17:19:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-17 17:19:49 +0000
commit12981c0075de291af7880057c93f66be322493b5 (patch)
treea446202a8125c2cc1034637fd9c4b534f32028c8 /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-12981c0075de291af7880057c93f66be322493b5.tar.gz
gentoo-2-12981c0075de291af7880057c93f66be322493b5.tar.bz2
gentoo-2-12981c0075de291af7880057c93f66be322493b5.zip
Version bump.
(Portage version: 2.2.0_alpha15_p12/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipdb/ChangeLog10
-rw-r--r--dev-python/ipdb/ipdb-0.3.ebuild26
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/ipdb/ChangeLog b/dev-python/ipdb/ChangeLog
index c89425d46bdb..631c20d72739 100644
--- a/dev-python/ipdb/ChangeLog
+++ b/dev-python/ipdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipdb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipdb/ChangeLog,v 1.4 2010/11/08 17:28:26 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipdb/ChangeLog,v 1.5 2011/01/17 17:19:49 arfrever Exp $
+
+*ipdb-0.3 (17 Jan 2011)
+
+ 17 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -ipdb-0.2.ebuild, +ipdb-0.3.ebuild:
+ Version bump.
*ipdb-0.2 (08 Nov 2010)
diff --git a/dev-python/ipdb/ipdb-0.3.ebuild b/dev-python/ipdb/ipdb-0.3.ebuild
new file mode 100644
index 000000000000..3a76f7419aa9
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipdb/ipdb-0.3.ebuild,v 1.1 2011/01/17 17:19:49 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+# This package theoretically supports Python 3, but dev-python/ipython does not support Python 3.
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="http://pypi.python.org/pypi/ipdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="HISTORY.txt"