summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-24 11:56:39 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-24 11:56:39 +0000
commit14446bc8a6594a078eaa71a20fdd91f8cf6705f3 (patch)
tree5522219cf106af641672dfd5003e89bf2ca54a5a /dev-python
parentCleanup mask entry (diff)
downloadgentoo-2-14446bc8a6594a078eaa71a20fdd91f8cf6705f3.tar.gz
gentoo-2-14446bc8a6594a078eaa71a20fdd91f8cf6705f3.tar.bz2
gentoo-2-14446bc8a6594a078eaa71a20fdd91f8cf6705f3.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygit2/ChangeLog7
-rw-r--r--dev-python/pygit2/pygit2-0.20.1.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index d33125c0476e..2cca43547a44 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.21 2013/11/24 23:13:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.22 2013/12/24 11:56:39 radhermit Exp $
+
+*pygit2-0.20.1 (24 Dec 2013)
+
+ 24 Dec 2013; Tim Harder <radhermit@gentoo.org> +pygit2-0.20.1.ebuild:
+ Version bump.
*pygit2-0.20.0 (24 Nov 2013)
diff --git a/dev-python/pygit2/pygit2-0.20.1.ebuild b/dev-python/pygit2/pygit2-0.20.1.ebuild
new file mode 100644
index 000000000000..4764f50cdf47
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.20.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.20.1.ebuild,v 1.1 2013/12/24 11:56:39 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}