summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 23:23:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 23:23:12 +0000
commit19a52eda012fc13834990160ca8c9552f69e5962 (patch)
treeb014ef38697610fce2e71fb628053637c450e108 /dev-python
parentamd64 stable, bug #279398 (diff)
downloadgentoo-2-19a52eda012fc13834990160ca8c9552f69e5962.tar.gz
gentoo-2-19a52eda012fc13834990160ca8c9552f69e5962.tar.bz2
gentoo-2-19a52eda012fc13834990160ca8c9552f69e5962.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14204-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/chaco/ChangeLog8
-rw-r--r--dev-python/chaco/chaco-3.2.0.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index a4751eea783d..329c553c37cc 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/chaco
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.3 2009/04/24 15:01:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.4 2009/09/05 23:23:12 arfrever Exp $
+
+*chaco-3.2.0 (05 Sep 2009)
+
+ 05 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +chaco-3.2.0.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
24 Apr 2009; Patrick Lauer <patrick@gentoo.org> -chaco-3.0.1.ebuild:
Remove old
diff --git a/dev-python/chaco/chaco-3.2.0.ebuild b/dev-python/chaco/chaco-3.2.0.ebuild
new file mode 100644
index 000000000000..173a87873a3c
--- /dev/null
+++ b/dev-python/chaco/chaco-3.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.2.0.ebuild,v 1.1 2009/09/05 23:23:12 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Chaco"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Interactive plotting toolkit"
+HOMEPAGE="http://code.enthought.com/projects/chaco"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+IUSE="doc examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND=">=dev-python/enable-3.2.0"
+DEPEND="dev-python/setuptools
+ >=dev-python/numpy-1.1
+ doc? ( app-arch/unzip )"
+# docs building and tests need an X display
+# doc? ( dev-python/setupdocs )
+# test? ( >=dev-python/nose-0.10.3
+# dev-python/coverage
+# >=dev-python/enable-3.2.0
+# >=dev-python/enthoughtbase-3.0.3 )"
+RESTRICT_PYTHON_ABIS="3.*"
+#RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ sed -i -e "s/self.run_command('build_docs')/pass/" setup.py || die
+}
+
+src_compile() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_compile
+ #if use doc; then
+ # ${python} setup.py build_docs --formats=html,pdf \
+ # || die "doc building failed"
+ #fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_install
+ dodoc docs/*.txt
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ #doins -r build/docs/html build/docs/latex/*.pdf || die
+ doins docs/*.pdf || die
+ unzip docs/html.zip
+ insinto /usr/share/doc/${PF}
+ doins -r html || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}