summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-11 13:52:58 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-11 13:52:58 +0000
commit22ebc9f2fcf8cc394738a812de79457adc483457 (patch)
treedc6f49fc495f097481bcee227a3eaf8cdc2fde78 /dev-python
parentBump to 6.5.6, remove old (diff)
downloadgentoo-2-22ebc9f2fcf8cc394738a812de79457adc483457.tar.gz
gentoo-2-22ebc9f2fcf8cc394738a812de79457adc483457.tar.bz2
gentoo-2-22ebc9f2fcf8cc394738a812de79457adc483457.zip
Wrap installed script properly. Add missing python-magic dep that causes auto-download to happen during install.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/eyeD3/ChangeLog8
-rw-r--r--dev-python/eyeD3/eyeD3-0.7.4-r2.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/eyeD3/ChangeLog b/dev-python/eyeD3/ChangeLog
index 8021cd99b4de..36c87f9c67df 100644
--- a/dev-python/eyeD3/ChangeLog
+++ b/dev-python/eyeD3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/eyeD3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.68 2014/04/01 09:19:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.69 2014/06/11 13:52:58 mgorny Exp $
+
+*eyeD3-0.7.4-r2 (11 Jun 2014)
+
+ 11 Jun 2014; Michał Górny <mgorny@gentoo.org> +eyeD3-0.7.4-r2.ebuild:
+ Wrap installed script properly. Add missing python-magic dep that causes auto-
+ download to happen during install.
*eyeD3-0.7.4-r1 (01 Apr 2014)
diff --git a/dev-python/eyeD3/eyeD3-0.7.4-r2.ebuild b/dev-python/eyeD3/eyeD3-0.7.4-r2.ebuild
new file mode 100644
index 000000000000..0d0e06336edc
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.7.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.7.4-r2.ebuild,v 1.1 2014/06/11 13:52:58 mgorny Exp $
+
+EAPI=5
+
+# For python3_{2,3}, see bugs 501338, 501340
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="http://eyed3.nicfit.net/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~amd64 ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${PN}-0.6.18-r1:0
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/paver[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # prevent the build system from installing unwrapped bash script
+ sed -i -e '/scripts/d' pavement.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ sed -e "s:python:${EPYTHON}:" bin/eyeD3 > "${TMPDIR}"/eyeD3 || die
+ python_doexe "${TMPDIR}"/eyeD3
+}
+
+python_install_all() {
+ dodoc AUTHORS ChangeLog README.rst
+ distutils-r1_python_install_all
+}