summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-08-23 07:52:52 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-08-23 07:52:52 +0000
commit26c375f51d3e4bd6083c4e439a8d2184c663625f (patch)
tree5c97f9b43e7f634c057232f09e075106074b6162 /dev-python
parentFix decoding error with Python 3.1 (bug 333361). (diff)
downloadgentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.tar.gz
gentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.tar.bz2
gentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.zip
Clean out old cruft.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/docutils/ChangeLog8
-rw-r--r--dev-python/docutils/docutils-0.5-r1.ebuild122
-rw-r--r--dev-python/docutils/docutils-0.7_pre6334.ebuild118
-rw-r--r--dev-python/docutils/files/docutils-0.3.7-extramodules.patch32
-rw-r--r--dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch13
5 files changed, 7 insertions, 286 deletions
diff --git a/dev-python/docutils/ChangeLog b/dev-python/docutils/ChangeLog
index 6974eb23e927..5c64e8239fad 100644
--- a/dev-python/docutils/ChangeLog
+++ b/dev-python/docutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/docutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/ChangeLog,v 1.119 2010/08/23 07:48:35 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/ChangeLog,v 1.120 2010/08/23 07:52:51 djc Exp $
+
+ 23 Aug 2010; Dirkjan Ochtman <djc@gentoo.org>
+ -files/docutils-0.3.7-extramodules.patch, -docutils-0.5-r1.ebuild,
+ -files/docutils-0.5-test_node_class_names-python-2.6.patch,
+ -docutils-0.7_pre6334.ebuild:
+ Clean out old cruft.
23 Aug 2010; Dirkjan Ochtman <djc@gentoo.org> docutils-0.7.ebuild:
Fix bug 333361: installation on Python 3 bombs out with decoding error.
diff --git a/dev-python/docutils/docutils-0.5-r1.ebuild b/dev-python/docutils/docutils-0.5-r1.ebuild
deleted file mode 100644
index f05d25193428..000000000000
--- a/dev-python/docutils/docutils-0.5-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.5-r1.ebuild,v 1.11 2010/02/06 15:58:17 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils multilib
-
-DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc..."
-HOMEPAGE="http://docutils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/docutils/${P}.tar.gz
- glep? ( mirror://gentoo/glep-0.4-r1.tbz2 )"
-
-LICENSE="public-domain PYTHON BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="glep emacs"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-# Emacs support is in PDEPEND to avoid a dependency cycle (bug #183242)
-PDEPEND="emacs? ( || ( >=app-emacs/rst-0.4 >=virtual/emacs-23 ) )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-EMP="${PN}-0.3.7"
-
-GLEP_SRC="${WORKDIR}/glep-0.4-r1"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-test_node_class_names-python-2.6.patch"
-
- # simplified algorithm to select installing optparse and textwrap
- epatch "${FILESDIR}/${EMP}-extramodules.patch"
-
- sed -i \
- -e 's/from distutils.core/from setuptools/' \
- setup.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # make roman.py available for the doc building process
- ln -s extras/roman.py
-
- pushd tools > /dev/null
-
- # Place html4css1.css in base directory. This makes sure the
- # generated reference to it is correct.
- cp ../docutils/writers/html4css1/html4css1.css ..
-
- PYTHONPATH=.. "$(PYTHON -f)" ./buildhtml.py --stylesheet-path=../html4css1.css --traceback .. || die "buildhtml.py failed"
-
- popd > /dev/null
-
- # clean up after the doc building
- rm roman.py html4css1.css
-}
-
-src_test() {
- cd test
-
- testing() {
- PYTHONPATH="../build-${PYTHON_ABI}/lib" ./alltests.py
- }
- python_execute_function testing
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-src_install() {
- DOCS="*.txt"
- distutils_src_install
-
- # Tools
- cd tools
- for tool in *.py; do
- dobin "${tool}"
- done
-
- # Docs
- cd "${S}"
- dohtml -r docs tools
- # Manually install the stylesheet file
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- for doc in $(find docs tools -name "*.txt"); do
- install_txt_doc "${doc}"
- done
-
- # installing Gentoo GLEP tools. Uses versioned GLEP distribution
- if use glep; then
- dobin ${GLEP_SRC}/glep.py || die "dobin failed"
-
- installation_of_glep_tools() {
- insinto $(python_get_sitedir)/docutils/readers
- newins ${GLEP_SRC}/glepread.py glep.py || die "newins reader failed"
- insinto $(python_get_sitedir)/docutils/transforms
- newins ${GLEP_SRC}/glepstrans.py gleps.py || die "newins transform failed"
- insinto $(python_get_sitedir)/docutils/writers
- doins -r ${GLEP_SRC}/glep_html || die "doins writer failed"
- }
- python_execute_function --action-message 'Installation of GLEP tools with Python ${PYTHON_ABI}...' installation_of_glep_tools
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize docutils roman.py
-}
-
-pkg_postrm() {
- python_mod_cleanup docutils roman.py
-}
diff --git a/dev-python/docutils/docutils-0.7_pre6334.ebuild b/dev-python/docutils/docutils-0.7_pre6334.ebuild
deleted file mode 100644
index db94483be791..000000000000
--- a/dev-python/docutils/docutils-0.7_pre6334.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.7_pre6334.ebuild,v 1.1 2010/06/02 18:20:41 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc..."
-HOMEPAGE="http://docutils.sourceforge.net/ http://pypi.python.org/pypi/docutils"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- glep? ( mirror://gentoo/glep-0.4-r1.tbz2 )"
-#mirror://sourceforge/docutils/${P}.tar.gz
-
-LICENSE="public-domain PYTHON BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="glep emacs"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-# Emacs support is in PDEPEND to avoid a dependency cycle (bug #183242)
-PDEPEND="emacs? ( || ( >=app-emacs/rst-0.4 >=virtual/emacs-23 ) )"
-
-DOCS="*.txt"
-
-GLEP_SRC="${WORKDIR}/glep-0.4-r1"
-
-src_prepare() {
- # Delete internal copies of optparse and textwrap modules.
- rm -f extras/{optparse.py,textwrap.py}
- # Fix installation of extra modules.
- epatch "${FILESDIR}/${PN}-0.6-extra_modules.patch"
-
- sed -e "s/from distutils.core/from setuptools/" -i setup.py || die "sed setup.py failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # Make roman.py available for the doc building process
- ln -s extras/roman.py
-
- # Place html4css1.css in base directory. This makes sure the
- # generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css .
-
- pushd tools > /dev/null
-
- echo PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --stylesheet-path=../html4css1.css --traceback ..
- PYTHONPATH="../build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" $([[ -f ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py ]] && echo ../build-$(PYTHON -f --ABI)/lib/tools/buildhtml.py || echo ../tools/buildhtml.py) --stylesheet-path=../html4css1.css --traceback .. || die "buildhtml.py failed"
-
- popd > /dev/null
-
- # Clean up after the doc building.
- rm roman.py html4css1.css
-}
-
-src_test() {
- testing() {
- echo PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $([[ -f build-${PYTHON_ABI}/lib/test/alltests.py ]] && echo build-${PYTHON_ABI}/lib/test/alltests.py || echo test/alltests.py)
- }
- python_execute_function testing
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-src_install() {
- distutils_src_install
-
- # Tools
- cd tools
- for tool in *.py; do
- dobin "${tool}"
- done
-
- # Docs
- cd "${S}"
- dohtml -r docs tools
- # Manually install the stylesheet file
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- for doc in $(find docs tools -name "*.txt"); do
- install_txt_doc "${doc}"
- done
-
- # installing Gentoo GLEP tools. Uses versioned GLEP distribution
- if use glep; then
- dobin ${GLEP_SRC}/glep.py || die "dobin failed"
-
- installation_of_glep_tools() {
- insinto $(python_get_sitedir)/docutils/readers
- newins ${GLEP_SRC}/glepread.py glep.py || die "newins reader failed"
- insinto $(python_get_sitedir)/docutils/transforms
- newins ${GLEP_SRC}/glepstrans.py gleps.py || die "newins transform failed"
- insinto $(python_get_sitedir)/docutils/writers
- doins -r ${GLEP_SRC}/glep_html || die "doins writer failed"
- }
- python_execute_function --action-message 'Installation of GLEP tools with $(python_get_implementation) $(python_get_version)...' installation_of_glep_tools
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize docutils roman.py
-}
-
-pkg_postrm() {
- python_mod_cleanup docutils roman.py
-}
diff --git a/dev-python/docutils/files/docutils-0.3.7-extramodules.patch b/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
deleted file mode 100644
index f5701d681cbe..000000000000
--- a/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- docutils-0.3.7/setup.py 2004-07-29 16:57:28.000000000 +0200
-+++ docutils-0.3.7/setup.py.new 2004-09-23 10:06:06.263010624 +0200
-@@ -82,20 +82,15 @@
- List of (module name, minimum __version__ string, [attribute names])."""
-
- def get_extras():
-- extras = []
-- for module_name, version, attributes in extra_modules:
-- try:
-- module = __import__(module_name)
-- if version and module.__version__ < version:
-- raise ValueError
-- for attribute in attributes or []:
-- getattr(module, attribute)
-- print ('"%s" module already present; ignoring extras/%s.py.'
-- % (module_name, module_name))
-- except (ImportError, AttributeError, ValueError):
-- extras.append(module_name)
-- return extras
--
-+ # old method does not work for upgrading/downgrading docutils.
-+ # so we use a simple rule, 'optparse' and 'textwrap' are not installed
-+ # for >=python-2.3
-+
-+ pyver = sys.version_info
-+ if pyver[0] == 2 and pyver[1] > 2:
-+ return ["roman"]
-+ else:
-+ return ["optparse","textwrap","roman"]
-
- class dual_build_py(build_py):
-
diff --git a/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch b/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch
deleted file mode 100644
index b55e392def58..000000000000
--- a/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://svn.berlios.de/viewcvs/docutils?view=rev&revision=5599
-
---- trunk/docutils/test/test_nodes.py
-+++ trunk/docutils/test/test_nodes.py
-@@ -175,7 +175,7 @@
- node_class_names = []
- for x in dir(nodes):
- c = getattr(nodes, x)
-- if isinstance(c, ClassType) and issubclass(c, nodes.Node) \
-+ if isinstance(c, (type, ClassType)) and issubclass(c, nodes.Node) \
- and len(c.__bases__) > 1:
- node_class_names.append(x)
- node_class_names.sort()