summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-13 05:26:40 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-13 05:26:40 +0000
commit3a3dd2c65d21f812f86825baefdaae550706bd10 (patch)
tree52f17cf01c8f7dccb62802b01bbf3c19f4863d6c /dev-python
parentRemove old development snapshots from the tree. (diff)
downloadgentoo-2-3a3dd2c65d21f812f86825baefdaae550706bd10.tar.gz
gentoo-2-3a3dd2c65d21f812f86825baefdaae550706bd10.tar.bz2
gentoo-2-3a3dd2c65d21f812f86825baefdaae550706bd10.zip
Add 2.6 series back since they are the only ones marked for mips
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/files/digest-pygtk-2.6.14
-rw-r--r--dev-python/pygtk/files/digest-pygtk-2.6.24
-rw-r--r--dev-python/pygtk/pygtk-2.6.1.ebuild83
-rw-r--r--dev-python/pygtk/pygtk-2.6.2.ebuild83
5 files changed, 179 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 2edf6b5865e9..9aa2183966b4 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.112 2006/05/12 16:07:35 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.113 2006/05/13 05:26:40 halcy0n Exp $
+
+ 13 May 2006; Mark Loeser <halcy0n@gentoo.org> +pygtk-2.6.1.ebuild,
+ +pygtk-2.6.2.ebuild:
+ Add 2.6 series back since they are the only ones marked for mips
12 May 2006; John N. Laliberte <allanonjl@gentoo.org> -pygtk-2.6.1.ebuild,
-pygtk-2.6.2.ebuild:
diff --git a/dev-python/pygtk/files/digest-pygtk-2.6.1 b/dev-python/pygtk/files/digest-pygtk-2.6.1
new file mode 100644
index 000000000000..1708d5094632
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-2.6.1
@@ -0,0 +1,4 @@
+MD5 b4610829e4f57b5538dfa3b8f1fbe026 pygtk-2.6.1.tar.bz2 729460
+MD5 b7c7f1aaaf24165d4cb2a5f4e2225d34 pygtk2reference.tbz2 604463
+RMD160 3d4d9c5d5616dc6876c3c01fafaeadc1d96ccade pygtk2reference.tbz2 604463
+SHA256 4f19595f2ecac6a7265e4f130efe7e4c8543afc6ad16429db0411be6e841849b pygtk2reference.tbz2 604463
diff --git a/dev-python/pygtk/files/digest-pygtk-2.6.2 b/dev-python/pygtk/files/digest-pygtk-2.6.2
new file mode 100644
index 000000000000..dadc67299c5b
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-2.6.2
@@ -0,0 +1,4 @@
+MD5 0d4dca0564fc867a976808d18443f059 pygtk-2.6.2.tar.bz2 731185
+MD5 b7c7f1aaaf24165d4cb2a5f4e2225d34 pygtk2reference.tbz2 604463
+RMD160 3d4d9c5d5616dc6876c3c01fafaeadc1d96ccade pygtk2reference.tbz2 604463
+SHA256 4f19595f2ecac6a7265e4f130efe7e4c8543afc6ad16429db0411be6e841849b pygtk2reference.tbz2 604463
diff --git a/dev-python/pygtk/pygtk-2.6.1.ebuild b/dev-python/pygtk/pygtk-2.6.1.ebuild
new file mode 100644
index 000000000000..3658e0c36da6
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.6.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.1.ebuild,v 1.15 2006/05/13 05:26:40 halcy0n Exp $
+
+inherit gnome.org python flag-o-matic
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+SRC_URI="${SRC_URI}
+ doc? ( http://www.pygtk.org/dist/pygtk2reference.tbz2 )"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="gnome opengl doc"
+
+RDEPEND=">=dev-lang/python-2.3
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.4.0
+ !arm? ( dev-python/numeric )
+ gnome? ( >=gnome-base/libglade-2.3.6 )
+ opengl? ( virtual/opengl
+ dev-python/pyopengl
+ >=x11-libs/gtkglarea-1.99 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ if use doc; then
+ unpack pygtk2reference.tbz2
+ fi
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf --enable-thread || die
+ # possible problems with parallel builds (#45776)
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+ rm examples/Makefile*
+ cp -r examples ${D}/usr/share/doc/${PF}/
+
+ python_version
+ mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+
+ if use doc; then
+ cd ${S}/../pygtk2reference
+ dohtml -r *
+ fi
+}
+
+src_test() {
+ cd tests
+ make check-local
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/share/pygtk/2.0/codegen
+ python_mod_cleanup
+ rm -f ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}
diff --git a/dev-python/pygtk/pygtk-2.6.2.ebuild b/dev-python/pygtk/pygtk-2.6.2.ebuild
new file mode 100644
index 000000000000..cbd55f194271
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.6.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.2.ebuild,v 1.3 2006/05/13 05:26:40 halcy0n Exp $
+
+inherit gnome.org python flag-o-matic
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+SRC_URI="${SRC_URI}
+ doc? ( http://www.pygtk.org/dist/pygtk2reference.tbz2 )"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome opengl doc"
+
+RDEPEND=">=dev-lang/python-2.3
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.4.0
+ !arm? ( dev-python/numeric )
+ gnome? ( >=gnome-base/libglade-2.3.6 )
+ opengl? ( virtual/opengl
+ dev-python/pyopengl
+ >=x11-libs/gtkglarea-1.99 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ if use doc; then
+ unpack pygtk2reference.tbz2
+ fi
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf --enable-thread || die
+ # possible problems with parallel builds (#45776)
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+ rm examples/Makefile*
+ cp -r examples ${D}/usr/share/doc/${PF}/
+
+ python_version
+ mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+
+ if use doc; then
+ cd ${S}/../pygtk2reference
+ dohtml -r *
+ fi
+}
+
+src_test() {
+ cd tests
+ make check-local
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/share/pygtk/2.0/codegen
+ python_mod_cleanup
+ rm -f ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}