summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-08-31 19:38:45 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-08-31 19:38:45 +0000
commit3b02de59a115eeb55642f88fc8ee15944c14191c (patch)
treefda5dfe7cdc437599932d7aaaffefce3c426cf76 /dev-python
parentadd net-www/mozilla-firefox:mozxmlterm for agriffis; sort (diff)
downloadgentoo-2-3b02de59a115eeb55642f88fc8ee15944c14191c.tar.gz
gentoo-2-3b02de59a115eeb55642f88fc8ee15944c14191c.tar.bz2
gentoo-2-3b02de59a115eeb55642f88fc8ee15944c14191c.zip
Add back sip-3.8* as it's needed by PyQt-3.8.1.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/Manifest5
-rw-r--r--dev-python/sip/files/digest-sip-3.8-r11
-rw-r--r--dev-python/sip/files/license-3.8.diff34
-rw-r--r--dev-python/sip/sip-3.8-r1.ebuild49
5 files changed, 95 insertions, 2 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 1088531dc087..a14804ac0b24 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.42 2004/08/30 15:29:29 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.43 2004/08/31 19:38:45 kloeri Exp $
+
+*sip-3.8-r1 (31 Aug 2004)
+
+ 31 Aug 2004; Bryan Østergaard,,, <kloeri@gentoo.org>
+ +files/license-3.8.diff, +sip-3.8-r1.ebuild:
+ Add back sip-3.8* as it's needed by PyQt-3.8.1.
30 Aug 2004; Carsten Lohrke <carlo@gentoo.org> -files/license-3.8.diff,
-sip-3.8-r1.ebuild, sip-4.0.1.ebuild, -sip-4.0.ebuild, -sip-4.0_rc2.ebuild,
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 094905d9abee..f99c6ebcd54c 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,6 +1,9 @@
MD5 5d20a3ba2b8812b91f7643c77e9a400b sip-4.0.1.ebuild 1054
-MD5 dc1b807ef9e422cdc2d41e678a260ab2 ChangeLog 5589
+MD5 16cede0c78703a06e1002a5206ea90b7 sip-3.8-r1.ebuild 1112
+MD5 b1a621a7fcacb0c8a4bcce55c24adc17 ChangeLog 5769
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
MD5 354c3ff99047b9012d51e0e42b4b3f34 sip-3.10.2.ebuild 983
MD5 6a011f04f4a2219a674a61dd82763301 files/digest-sip-4.0.1 61
MD5 e052f291e46bb8d1de4cfb1b45aeac88 files/digest-sip-3.10.2 62
+MD5 821af86e779d5bc5b3457336a0426fa1 files/digest-sip-3.8-r1 67
+MD5 70ee7d5fd80e0bec5823095ca853d455 files/license-3.8.diff 1003
diff --git a/dev-python/sip/files/digest-sip-3.8-r1 b/dev-python/sip/files/digest-sip-3.8-r1
new file mode 100644
index 000000000000..9093f9dd6006
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.8-r1
@@ -0,0 +1 @@
+MD5 2144b29adca9ff7b3b03de266da6c2eb sip-x11-gpl-3.8.tar.gz 179221
diff --git a/dev-python/sip/files/license-3.8.diff b/dev-python/sip/files/license-3.8.diff
new file mode 100644
index 000000000000..5fba51163375
--- /dev/null
+++ b/dev-python/sip/files/license-3.8.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2003-07-30 22:07:12.000000000 +0000
++++ build.py 2003-07-30 22:07:57.000000000 +0000
+@@ -675,31 +675,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of SIP and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ proPatches["@BLX_SIP_LICENSE@"] = licType
+
+ inform("Building the %s version of SIP 3.7 for Python %s on %s." % (licType,pyFullVers,sys.platform))
diff --git a/dev-python/sip/sip-3.8-r1.ebuild b/dev-python/sip/sip-3.8-r1.ebuild
new file mode 100644
index 000000000000..1a33eef8bf1d
--- /dev/null
+++ b/dev-python/sip/sip-3.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.8-r1.ebuild,v 1.10 2004/08/31 19:38:45 kloeri Exp $
+
+inherit eutils distutils
+
+MY_P="${PN}-x11-gpl-${PV}"
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE=""
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ >=dev-lang/python-2.2.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/license-${PV}.diff
+}
+
+src_compile(){
+ distutils_python_version
+
+ chmod +x build.py
+ dodir /usr/bin
+ dodir /usr/lib/python${PYVER}/site-packages
+ python build.py -l qt-mt \
+ -b ${D}/usr/bin \
+ -d ${D}/usr/lib/python${PYVER}/site-packages \
+ -e ${D}/usr/include/python${PYVER}
+
+ emake || die
+}
+
+src_install() {
+ distutils_python_version
+ dodir /usr/include/python${PYVER}
+ emake || die
+ einstall || die
+ dodoc NEWS README THANKS
+}