summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-05 22:21:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-05 22:21:06 +0000
commit41fb07e1a7a7f41f78e52b8d911ae8fc0f158024 (patch)
tree0598de340be1e5022065ec8cb0aaf799c6e3c461 /dev-python
parentfix incompatibility introduced in file 5.05 (diff)
downloadgentoo-2-41fb07e1a7a7f41f78e52b8d911ae8fc0f158024.tar.gz
gentoo-2-41fb07e1a7a7f41f78e52b8d911ae8fc0f158024.tar.bz2
gentoo-2-41fb07e1a7a7f41f78e52b8d911ae8fc0f158024.zip
Fix dependencies. Restrict Jython ABIs. Add src_test().
(Portage version: 2.2.0_alpha26_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild b/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild
index 9bca6460ce4b..5bc457fd3442 100644
--- a/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild
+++ b/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild,v 1.1 2011/03/05 21:30:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyusb/pyusb-1.0.0_alpha1.ebuild,v 1.2 2011/03/05 22:21:06 arfrever Exp $
-EAPI="2"
-inherit distutils flag-o-matic
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
MY_P="${P/_alpha/-a}"
+
DESCRIPTION="USB support for Python."
HOMEPAGE="http://pyusb.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
@@ -18,6 +23,16 @@ IUSE=""
### This version is compatible with both 0.X and 1.X versions of libusb
DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
-PYTHON_DEPEND="*:2.5"
S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="usb"
+
+src_test() {
+ cd tests
+
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" testall.py
+ }
+ python_execute_function testing
+}