summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-09 15:42:55 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-09 15:42:55 +0000
commit4504ad85cbe92d307c2d817a7a07965add02a5a6 (patch)
treea0c607fd668968d75729575cb2973064b729146b /dev-python
parentCleanup old patches. (diff)
downloadgentoo-2-4504ad85cbe92d307c2d817a7a07965add02a5a6.tar.gz
gentoo-2-4504ad85cbe92d307c2d817a7a07965add02a5a6.tar.bz2
gentoo-2-4504ad85cbe92d307c2d817a7a07965add02a5a6.zip
Migrate to twisted-r1.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/epsilon/ChangeLog7
-rw-r--r--dev-python/epsilon/epsilon-0.6.0-r2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/epsilon/ChangeLog b/dev-python/epsilon/ChangeLog
index c16d69f87968..dd3eece8997f 100644
--- a/dev-python/epsilon/ChangeLog
+++ b/dev-python/epsilon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/epsilon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.29 2013/08/03 09:45:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.30 2013/08/09 15:42:55 mgorny Exp $
+
+*epsilon-0.6.0-r2 (09 Aug 2013)
+
+ 09 Aug 2013; Michał Górny <mgorny@gentoo.org> +epsilon-0.6.0-r2.ebuild:
+ Migrate to twisted-r1.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> epsilon-0.6.0.ebuild,
epsilon-0.6.0-r1.ebuild:
diff --git a/dev-python/epsilon/epsilon-0.6.0-r2.ebuild b/dev-python/epsilon/epsilon-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..5d44bdabad17
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.6.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.6.0-r2.ebuild,v 1.1 2013/08/09 15:42:55 mgorny Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon http://pypi.python.org/pypi/Epsilon"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}