summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-11 07:51:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-11 07:51:49 +0000
commit4cbe1c2e047985e63b50066fa73cb0d8f2992379 (patch)
tree8ff53957367e9279e0db5917b5b4f8ae09d6c1ef /dev-python
parentx86 stable, see bug 411487 (diff)
downloadgentoo-2-4cbe1c2e047985e63b50066fa73cb0d8f2992379.tar.gz
gentoo-2-4cbe1c2e047985e63b50066fa73cb0d8f2992379.tar.bz2
gentoo-2-4cbe1c2e047985e63b50066fa73cb0d8f2992379.zip
Bump for #411403
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-distutils-extra/ChangeLog8
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/python-distutils-extra/ChangeLog b/dev-python/python-distutils-extra/ChangeLog
index 59ff6c121a6f..54a2a93e2539 100644
--- a/dev-python/python-distutils-extra/ChangeLog
+++ b/dev-python/python-distutils-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-distutils-extra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.10 2012/02/01 21:57:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.11 2012/04/11 07:51:49 patrick Exp $
+
+*python-distutils-extra-2.32 (11 Apr 2012)
+
+ 11 Apr 2012; Patrick Lauer <patrick@gentoo.org>
+ +python-distutils-extra-2.32.ebuild:
+ Bump for #411403
01 Feb 2012; Brent Baude <ranger@gentoo.org>
python-distutils-extra-2.23.ebuild:
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild
new file mode 100644
index 000000000000..e80593caa3ed
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild,v 1.1 2012/04/11 07:51:49 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils."
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
+PYTHON_MODNAME="DistUtilsExtra"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" \
+ -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" \
+ -e "s/test_requires_provides/_&/" \
+ -i test/auto.py
+}
+
+src_test() {
+ # 5 tests fail with disabled byte-compilation.
+ python_enable_pyc
+
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/auto.py
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}