summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-09 00:11:13 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-09 00:11:13 +0000
commit4e7dd0ccc01295232691df4255bae66f1675d190 (patch)
tree51d8f81c93b2c3b8ec6eadc22f6a393f183f4ba3 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-4e7dd0ccc01295232691df4255bae66f1675d190.tar.gz
gentoo-2-4e7dd0ccc01295232691df4255bae66f1675d190.tar.bz2
gentoo-2-4e7dd0ccc01295232691df4255bae66f1675d190.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xmltodict/ChangeLog7
-rw-r--r--dev-python/xmltodict/xmltodict-0.9.2.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/xmltodict/ChangeLog b/dev-python/xmltodict/ChangeLog
index c61e63f32429..4aea1d8e782b 100644
--- a/dev-python/xmltodict/ChangeLog
+++ b/dev-python/xmltodict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xmltodict
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.12 2015/01/26 11:13:40 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.13 2015/02/09 00:11:13 radhermit Exp $
+
+*xmltodict-0.9.2 (09 Feb 2015)
+
+ 09 Feb 2015; Tim Harder <radhermit@gentoo.org> +xmltodict-0.9.2.ebuild:
+ Version bump.
26 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -xmltodict-0.9.0.ebuild:
Remove old.
diff --git a/dev-python/xmltodict/xmltodict-0.9.2.ebuild b/dev-python/xmltodict/xmltodict-0.9.2.ebuild
new file mode 100644
index 000000000000..ec3164e8c062
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.9.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.9.2.ebuild,v 1.1 2015/02/09 00:11:13 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}