summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-26 21:49:08 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-26 21:49:08 +0000
commit5472e457fdb63bfad7e3dce6ba3b8a60b25181fc (patch)
treeea2e181797108bf1240e57d2f184f2907d2b31b2 /dev-python
parentDrop old (diff)
downloadgentoo-2-5472e457fdb63bfad7e3dce6ba3b8a60b25181fc.tar.gz
gentoo-2-5472e457fdb63bfad7e3dce6ba3b8a60b25181fc.tar.bz2
gentoo-2-5472e457fdb63bfad7e3dce6ba3b8a60b25181fc.zip
re-add version 0.11.0.
Seems fig still requires a particular version of websocket-client. Re-adding it until fig dependences can be verified. (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/websocket-client/ChangeLog9
-rw-r--r--dev-python/websocket-client/websocket-client-0.11.0.ebuild30
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/websocket-client/ChangeLog b/dev-python/websocket-client/ChangeLog
index 365cd921be2a..952f26e831dd 100644
--- a/dev-python/websocket-client/ChangeLog
+++ b/dev-python/websocket-client/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/websocket-client
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/ChangeLog,v 1.5 2014/10/26 17:07:50 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/ChangeLog,v 1.6 2014/10/26 21:49:08 alunduil Exp $
+
+*websocket-client-0.11.0 (26 Oct 2014)
+
+ 26 Oct 2014; Alex Brandt <alunduil@gentoo.org>
+ +websocket-client-0.11.0.ebuild:
+ re-add version 0.11.0. Seems fig still requires a particular version of
+ websocket-client. Re-adding it until fig dependences can be verified.
26 Oct 2014; Alex Brandt <alunduil@gentoo.org>
-websocket-client-0.11.0.ebuild:
diff --git a/dev-python/websocket-client/websocket-client-0.11.0.ebuild b/dev-python/websocket-client/websocket-client-0.11.0.ebuild
new file mode 100644
index 000000000000..f013eec92705
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/websocket-client-0.11.0.ebuild,v 1.4 2014/10/26 21:49:08 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="WebSocket client for python. hybi13 is supported"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" test_websocket.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}