summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-01-12 05:46:23 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-01-12 05:46:23 +0000
commit5c5cb7c01919d94fb2aa128bf447a4ffd8708775 (patch)
treeeba7ab392eb9a7a164efb4d7d6846478f8e6bf23 /dev-python
parentBump to 1.5.12, remove old, always use the gdk-pixbuf backend, cogl2 referenc... (diff)
downloadgentoo-2-5c5cb7c01919d94fb2aa128bf447a4ffd8708775.tar.gz
gentoo-2-5c5cb7c01919d94fb2aa128bf447a4ffd8708775.tar.bz2
gentoo-2-5c5cb7c01919d94fb2aa128bf447a4ffd8708775.zip
Bump to 1.3.2, masked since it needs clutter-1.4
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyclutter/ChangeLog9
-rw-r--r--dev-python/pyclutter/pyclutter-1.3.2.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/pyclutter/ChangeLog b/dev-python/pyclutter/ChangeLog
index 73d97118af6a..f4d3d1858a6b 100644
--- a/dev-python/pyclutter/ChangeLog
+++ b/dev-python/pyclutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyclutter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclutter/ChangeLog,v 1.2 2010/06/26 02:34:44 nirbheek Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclutter/ChangeLog,v 1.3 2011/01/12 05:46:23 nirbheek Exp $
+
+*pyclutter-1.3.2 (12 Jan 2011)
+
+ 12 Jan 2011; <nirbheek@gentoo.org> +pyclutter-1.3.2.ebuild:
+ Bump to 1.3.2, masked since it needs clutter-1.4
*pyclutter-1.0.2 (26 Jun 2010)
diff --git a/dev-python/pyclutter/pyclutter-1.3.2.ebuild b/dev-python/pyclutter/pyclutter-1.3.2.ebuild
new file mode 100644
index 000000000000..f803bbb4df8b
--- /dev/null
+++ b/dev-python/pyclutter/pyclutter-1.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclutter/pyclutter-1.3.2.ebuild,v 1.1 2011/01/12 05:46:23 nirbheek Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils python clutter
+
+DESCRIPTION="Python bindings for Clutter"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+SLOT="1.0"
+RDEPEND=">=dev-lang/python-2.5
+ >=dev-python/pygtk-2.8.0
+ >=dev-python/pygobject-2.21.3
+ >=dev-python/pycairo-1.0.2
+ >=media-libs/clutter-1.4.0:${SLOT}"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt )"
+EXAMPLES="examples/{*.py,*.png}"
+
+src_configure() {
+ ln -sf $(type -P true) py-compile
+ local myconf="
+ --with-clutterx11=yes
+ --with-clutterglx=yes
+ $(use_enable doc docs)"
+
+ econf ${myconf}
+}
+
+src_install() {
+ # FIXME: Parallel make failure in emake install
+ MAKEOPTS="-j1" clutter_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/clutter
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/python*/site-packages/clutter
+}