summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-05 18:08:18 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-05 18:08:18 +0000
commit5ef0bfa0b3956a0f8f4f456cb0b91d7076f8a5c6 (patch)
tree31deff9f8648a334d6387d623435b8fede7d3718 /dev-python
parentVersion Bump; drop old (diff)
downloadgentoo-2-5ef0bfa0b3956a0f8f4f456cb0b91d7076f8a5c6.tar.gz
gentoo-2-5ef0bfa0b3956a0f8f4f456cb0b91d7076f8a5c6.tar.bz2
gentoo-2-5ef0bfa0b3956a0f8f4f456cb0b91d7076f8a5c6.zip
Version Bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-cache/ChangeLog7
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.10.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/requests-cache/ChangeLog b/dev-python/requests-cache/ChangeLog
index 336b325bf336..186b6ac71a2d 100644
--- a/dev-python/requests-cache/ChangeLog
+++ b/dev-python/requests-cache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests-cache
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.16 2015/03/27 17:00:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.17 2015/05/05 18:08:18 jlec Exp $
+
+*requests-cache-0.4.10 (05 May 2015)
+
+ 05 May 2015; Justin Lecher <jlec@gentoo.org> +requests-cache-0.4.10.ebuild:
+ Version Bump
27 Mar 2015; Justin Lecher <jlec@gentoo.org> -requests-cache-0.4.5.ebuild,
-requests-cache-0.4.6.ebuild, -requests-cache-0.4.8.ebuild, metadata.xml:
diff --git a/dev-python/requests-cache/requests-cache-0.4.10.ebuild b/dev-python/requests-cache/requests-cache-0.4.10.ebuild
new file mode 100644
index 000000000000..52fb96c283aa
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.4.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/requests-cache-0.4.10.ebuild,v 1.1 2015/05/05 18:08:18 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.python.org/pypi/requests-cache"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Portage only has versions of request >= minimum border
+RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}