summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-01 14:57:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-01 14:57:03 +0000
commit61ffe2632ec2ac67674cf069b175f6959f042e0e (patch)
tree8895d3f0a9b2b8fe7eb676cf9f85f01efd96fded /dev-python
parentRemove old. Remove silly DEPEND. (diff)
downloadgentoo-2-61ffe2632ec2ac67674cf069b175f6959f042e0e.tar.gz
gentoo-2-61ffe2632ec2ac67674cf069b175f6959f042e0e.tar.bz2
gentoo-2-61ffe2632ec2ac67674cf069b175f6959f042e0e.zip
Initial import, ebuild from sunrise overlay. Thanks to idl0r and all the others who worked on this in the last 2 years.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysvn/ChangeLog11
-rw-r--r--dev-python/pysvn/files/skip-root-test.patch20
-rw-r--r--dev-python/pysvn/metadata.xml5
-rw-r--r--dev-python/pysvn/pysvn-1.6.3-r1.ebuild87
4 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
new file mode 100644
index 000000000000..d26a318ba19d
--- /dev/null
+++ b/dev-python/pysvn/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/pysvn
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.1 2009/04/01 14:57:02 patrick Exp $
+
+*pysvn-1.6.3-r1 (01 Apr 2009)
+
+ 01 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/skip-root-test.patch, +metadata.xml, +pysvn-1.6.3-r1.ebuild:
+ Initial import, ebuild from sunrise overlay. Thanks to idl0r and all the
+ others who worked on this in the last 2 years.
+
diff --git a/dev-python/pysvn/files/skip-root-test.patch b/dev-python/pysvn/files/skip-root-test.patch
new file mode 100644
index 000000000000..52c01785f6fc
--- /dev/null
+++ b/dev-python/pysvn/files/skip-root-test.patch
@@ -0,0 +1,20 @@
+--- Tests/pysvn_test_common.mak.old 2008-10-02 22:30:42.000000000 +0200
++++ Tests/pysvn_test_common.mak 2009-03-11 19:22:17.192351068 +0100
+@@ -85,9 +85,14 @@ new-05: test-05.unix.new.log
+ cp test-05.unix.new.log test-05.unix.known_good-$(SVN_VERSION_MAJ_MIN).log
+
+ test-06.unix.new.log: test-06.sh test-06.unix.known_good-$(SVN_VERSION_MAJ_MIN).log
+- -rm -rf testroot-06
+- if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then PATH=$(SVN_BIN_DIR):$(PATH) PYTHON=$(PYTHON) ./test-06.sh >test-06.unix.new.log 2>&1; fi
+- if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then $(PYTHON) benchmark_diff.py test-06.unix.known_good-$(SVN_VERSION_MAJ_MIN).log test-06.unix.new.log; fi
++ if [[ $${UID} -ne 0 ]]; \
++ then \
++ rm -f testroot-06; \
++ if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then PATH=$(SVN_BIN_DIR):$(PATH) PYTHON=$(PYTHON) ./test-06.sh >test-06.unix.new.log 2>&1; fi; \
++ if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then $(PYTHON) benchmark_diff.py test-06.unix.known_good-$(SVN_VERSION_MAJ_MIN).log test-06.unix.new.log; fi; \
++ else \
++ echo "Skipping $@, Reason: executed as root"; \
++ fi
+
+ clean-06:
+ -rm -f test-06.unix.new.log
diff --git a/dev-python/pysvn/metadata.xml b/dev-python/pysvn/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/pysvn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pysvn/pysvn-1.6.3-r1.ebuild b/dev-python/pysvn/pysvn-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..209472ee2a1b
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.6.3-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.6.3-r1.ebuild,v 1.1 2009/04/01 14:57:02 patrick Exp $
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-util/subversion"
+# >=dev-python/pycxx-5.5.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/Source"
+
+src_unpack() {
+ python_version
+
+ unpack ${A}
+
+ # skip test test-06 if executed as root otherwise it will fail
+ cd "${S/Source/}"
+ epatch "${FILESDIR}/skip-root-test.patch"
+
+ cd "${S}"
+
+ # since pysvn-1.6.3: These sources are not compatible with python =< 2.5
+ # run the backport command to fix
+ if [[ $PYVER_MAJOR -eq 2 ]] && [[ $PYVER_MINOR -lt 6 ]]; then
+ einfo "prepare sources for python prior 2.6"
+ python setup.py backport || die "backport failed"
+ fi
+
+ # needed to generate the Makefile
+ python setup.py configure || die "configure failed"
+
+ # we want our CFLAGS as well
+ sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -i Makefile \
+ || die "sed failed in Makefile"
+}
+
+src_test() {
+ vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ emake test || die "test-pysvn.so failed"
+ emake -C ../Tests || die "test failed"
+ vecho ">>> Test phase [none]: ${CATEGORY}/${PF}"
+}
+
+src_install() {
+ local sitedir="$(python_get_sitedir)/${PN}"
+
+ cd pysvn/
+
+ exeinto ${sitedir}
+ doexe _pysvn*.so || die "doexe failed"
+ insinto ${sitedir}
+ doins __init__.py || die "doins failed"
+
+ cd ../
+
+ if use doc; then
+ dohtml -r ../Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc ../Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(python_get_sitedir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "$(python_get_sitedir)/${PN}"
+}