summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-10 20:58:29 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-10 20:58:29 +0000
commit63d081c6d7e97eadd700721cdd5918f689b4dcee (patch)
treee41ab6819ed66923691bbb804cf1f4ddae3fe5aa /dev-python
parentRemove old. (diff)
downloadgentoo-2-63d081c6d7e97eadd700721cdd5918f689b4dcee.tar.gz
gentoo-2-63d081c6d7e97eadd700721cdd5918f689b4dcee.tar.bz2
gentoo-2-63d081c6d7e97eadd700721cdd5918f689b4dcee.zip
Remove old.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/ChangeLog6
-rw-r--r--dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch19
-rw-r--r--dev-python/shiboken/shiboken-1.1.0.ebuild44
3 files changed, 5 insertions, 64 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index f914ca07bef1..92208e87f15b 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.21 2012/03/13 21:48:31 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.22 2012/04/10 20:58:28 pesa Exp $
+
+ 10 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ -files/shiboken-1.0.9-fix-pkgconfig.patch, -shiboken-1.1.0.ebuild:
+ Remove old.
13 Mar 2012; Davide Pesavento <pesa@gentoo.org> shiboken-1.1.0-r2.ebuild:
Use "-python${PYTHON_ABI}" instead of "$(PYTHON)" as suffix, for consistency
diff --git a/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch b/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch
deleted file mode 100644
index 8df2c65d292e..000000000000
--- a/dev-python/shiboken/files/shiboken-1.0.9-fix-pkgconfig.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -urN shiboken-1.0.9/data/shiboken.pc.in shiboken-1.0.9/data/shiboken.pc.in
---- shiboken-1.0.9/data/shiboken.pc.in 2011-09-06 12:36:36.150737026 +0200
-+++ shiboken-1.0.9/data/shiboken.pc.in 2011-09-06 12:38:30.780735651 +0200
-@@ -1,7 +1,8 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- exec_prefix=@CMAKE_INSTALL_PREFIX@
- libdir=@LIB_INSTALL_DIR@
--includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken
-+shiboken_SUFFIX=@shiboken_SUFFIX@
-+includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken${shiboken_SUFFIX}
- generator_location=@CMAKE_INSTALL_PREFIX@/bin/@SHIBOKEN_GENERATOR@
- python_interpreter=@PYTHON_EXECUTABLE@
- python_include_dir=@SBK_PYTHON_INCLUDE_DIR@
-@@ -10,5 +11,5 @@
- Description: Support library for Python bindings created with Shiboken generator.
- Version: @shiboken_VERSION@
- Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken@shiboken_SUFFIX@@PYTHON_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
--Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/@shiboken_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
-+Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/
diff --git a/dev-python/shiboken/shiboken-1.1.0.ebuild b/dev-python/shiboken/shiboken-1.1.0.ebuild
deleted file mode 100644
index 07a06e0e2077..000000000000
--- a/dev-python/shiboken/shiboken-1.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.0.ebuild,v 1.1 2012/01/15 11:23:11 hwoarang Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2:2.5"
-
-inherit python versionator cmake-utils
-
-MY_PV=$(replace_version_separator '_' '~')
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="A tool for creating Python bindings for C++ libraries"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug test"
-
-DEPEND=">=dev-python/apiextractor-0.10.10
- >=dev-python/generatorrunner-0.6.16
- >=x11-libs/qt-core-4.7.0"
-RDEPEND="${DEPEND}
- !dev-python/boostpythongenerator"
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.9-fix-pkgconfig.patch" )
-
-DOCS=( ChangeLog )
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build test TESTS)
- )
- cmake-utils_src_configure
-}