summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-28 16:42:27 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-28 16:42:27 +0000
commit668e494466ec7859d9934e3d9cc68054016510f6 (patch)
tree78b0bcbcd5d4eadde6af8799048af2d7cbf6c6e3 /dev-python
parentInitial commit, wrt bug #459626 (diff)
downloadgentoo-2-668e494466ec7859d9934e3d9cc68054016510f6.tar.gz
gentoo-2-668e494466ec7859d9934e3d9cc68054016510f6.tar.bz2
gentoo-2-668e494466ec7859d9934e3d9cc68054016510f6.zip
Let autotools compile the bytecode. Fix compressing examples. Enable tests.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/notify-python/ChangeLog5
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r3.ebuild23
2 files changed, 14 insertions, 14 deletions
diff --git a/dev-python/notify-python/ChangeLog b/dev-python/notify-python/ChangeLog
index 4544820756f0..d5aead0652a4 100644
--- a/dev-python/notify-python/ChangeLog
+++ b/dev-python/notify-python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/notify-python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.39 2013/02/20 10:44:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.40 2013/02/28 16:42:27 mgorny Exp $
+
+ 28 Feb 2013; Michał Górny <mgorny@gentoo.org> notify-python-0.1.1-r3.ebuild:
+ Let autotools compile the bytecode. Fix compressing examples. Enable tests.
*notify-python-0.1.1-r3 (20 Feb 2013)
diff --git a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
index 565bf90b5eea..cb90bd21300d 100644
--- a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
+++ b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1-r3.ebuild,v 1.1 2013/02/20 10:44:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1-r3.ebuild,v 1.2 2013/02/28 16:42:27 mgorny Exp $
EAPI=5
@@ -26,10 +26,6 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
src_prepare() {
- # Disable byte-compilation.
- rm -f py-compile || die
- ln -s $(type -P true) py-compile || die
-
# Remove the old pynotify.c to ensure it's properly regenerated #212128.
rm -f src/pynotify.c || die
autotools-utils_src_prepare
@@ -43,17 +39,18 @@ src_compile() {
python_foreach_impl autotools-utils_src_compile
}
+src_test() {
+ python_foreach_impl autotools-utils_src_test
+}
+
src_install() {
- installation() {
- autotools-utils_src_install
- python_optimize "${D}"$(python_get_sitedir)
- prune_libtool_files --all
- }
- python_foreach_impl installation
+ python_foreach_impl autotools-utils_src_install
+ prune_libtool_files --all
# Requested from bug 351879.
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins tests/*.{png,py}
+ docinto examples
+ dodoc tests/*.{png,py}
+ docompress -x /usr/share/doc/${PF}/examples
fi
}