summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 17:12:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 17:12:57 +0000
commit740266313e890a72197072531e20ac1be948238a (patch)
tree71e508f64d348fbb9e4a8e71f61afebdbc083413 /dev-python
parentSilent bump to ooo-build 3.2.0.6 patchset, minor fixes (diff)
downloadgentoo-2-740266313e890a72197072531e20ac1be948238a.tar.gz
gentoo-2-740266313e890a72197072531e20ac1be948238a.tar.bz2
gentoo-2-740266313e890a72197072531e20ac1be948238a.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jinja2/jinja2-2.3.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/jinja2/jinja2-2.3.ebuild b/dev-python/jinja2/jinja2-2.3.ebuild
deleted file mode 100644
index e303f5d554db..000000000000
--- a/dev-python/jinja2/jinja2-2.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja2/jinja2-2.3.ebuild,v 1.1 2010/02/10 08:51:42 djc Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="http://pypi.python.org/packages/source/J/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-SLOT="0"
-IUSE="doc examples i18n test"
-
-CDEPEND="dev-python/setuptools"
-DEPEND="${CDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/nose )"
-RDEPEND="${CDEPEND}
- i18n? ( >=dev-python/Babel-0.9.3 )"
-RESTRICT_PYTHON_ABIS="3.*" # test suite doesn't work on 3.x
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
-DOCS="CHANGES"
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- cd "${S}/docs"
- PYTHONPATH=.. emake html || die "Building of documentation failed"
- fi
-}
-
-src_test(){
- testing() {
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI} -v || return 1
- }
- python_execute_function testing
-}
-
-src_install(){
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- # Eliminate .pyc files going into /usr/share
- find examples -name "*.pyc" -print0 | xargs -0 rm -fr
-
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}