summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-26 21:39:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-26 21:39:56 +0000
commit7dd45e7a5cc25c6786f70b26e125b15817df25a7 (patch)
tree0a39a17b55639a460d8eef802f38a29a2972cc6f /dev-python
parentBump to 2.2.4. Remove old revisions. (diff)
downloadgentoo-2-7dd45e7a5cc25c6786f70b26e125b15817df25a7.tar.gz
gentoo-2-7dd45e7a5cc25c6786f70b26e125b15817df25a7.tar.bz2
gentoo-2-7dd45e7a5cc25c6786f70b26e125b15817df25a7.zip
Added qt-xmlpatterns as dependency. Apply patch from but #267012
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog11
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r4.ebuild65
-rw-r--r--dev-python/PyQt4/files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch16
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 6f1ef795c96c..7e5047593da9 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.53 2009/04/07 18:30:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.54 2009/04/26 21:39:55 hwoarang Exp $
+
+*PyQt4-4.4.4-r4 (26 Apr 2009)
+
+ 26 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
+ +PyQt4-4.4.4-r4.ebuild:
+ Adding qt-xmlpatterns as dependency. Add patch for QGraphicsProxyWidget (
+ thanks to Fabio Erculiani <lxnay@sabayonlinux.org> for providing the patch
+ ). Fixes bug #267012
*PyQt4-4.4.4-r3 (07 Apr 2009)
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r4.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r4.ebuild
new file mode 100644
index 000000000000..cb16c86eb042
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.4.4-r4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r4.ebuild,v 1.1 2009/04/26 21:39:55 hwoarang Exp $
+
+EAPI="2"
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt4/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus debug doc examples opengl qt3support svg webkit X"
+
+RDEPEND=">=dev-python/sip-4.7.8
+ >=x11-libs/qt-core-4.4.2:4
+ >=x11-libs/qt-xmlpatterns-4.4.2:4
+ dbus? ( dev-python/dbus-python
+ >=x11-libs/qt-dbus-4.4.2:4 )
+ opengl? ( >=x11-libs/qt-opengl-4.4.2:4 )
+ svg? ( >=x11-libs/qt-svg-4.4.2:4 )
+ qt3support? ( >=x11-libs/qt-qt3support-4.4.2:4 )
+ webkit? ( >=x11-libs/qt-webkit-4.4.2:4 )
+ X? ( >=x11-libs/qt-gui-4.4.2:4 )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/configure.py.patch"
+ "${FILESDIR}/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch"
+)
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_configure() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch b/dev-python/PyQt4/files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch
new file mode 100644
index 000000000000..9c811b849ec5
--- /dev/null
+++ b/dev-python/PyQt4/files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch
@@ -0,0 +1,16 @@
+diff -Nurp PyQt-x11-gpl-4.4.4.orig/sip/QtGui/qgraphicsproxywidget.sip PyQt-x11-gpl-4.4.4/sip/QtGui/qgraphicsproxywidget.sip
+--- PyQt-x11-gpl-4.4.4.orig/sip/QtGui/qgraphicsproxywidget.sip 2008-11-08 12:55:56.000000000 +0100
++++ PyQt-x11-gpl-4.4.4/sip/QtGui/qgraphicsproxywidget.sip 2009-04-21 21:59:09.938689971 +0200
+@@ -87,6 +87,12 @@ protected:
+ virtual void mousePressEvent(QGraphicsSceneMouseEvent *event);
+ virtual void mouseReleaseEvent(QGraphicsSceneMouseEvent *event);
+ virtual void mouseDoubleClickEvent(QGraphicsSceneMouseEvent *event);
++
++ virtual void dragEnterEvent(QGraphicsSceneDragDropEvent *event);
++ virtual void dragLeaveEvent(QGraphicsSceneDragDropEvent *event);
++ virtual void dragMoveEvent(QGraphicsSceneDragDropEvent *event);
++ virtual void dropEvent(QGraphicsSceneDragDropEvent *event);
++
+ virtual void wheelEvent(QGraphicsSceneWheelEvent *event);
+ virtual void keyPressEvent(QKeyEvent *event);
+ virtual void keyReleaseEvent(QKeyEvent *event);