summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 13:30:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 13:30:30 +0000
commit8198c205c92bc8f6b53eea745bf71f3cd963dbbc (patch)
treeb4eef3085bc4ea78ca2e0d57a6d7c16f95505c5c /dev-python
parentVersion bump. (diff)
downloadgentoo-2-8198c205c92bc8f6b53eea745bf71f3cd963dbbc.tar.gz
gentoo-2-8198c205c92bc8f6b53eea745bf71f3cd963dbbc.tar.bz2
gentoo-2-8198c205c92bc8f6b53eea745bf71f3cd963dbbc.zip
Initial addition.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/ChangeLog10
-rw-r--r--dev-python/pytest/metadata.xml5
-rw-r--r--dev-python/pytest/pytest-2.0.0.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
new file mode 100644
index 000000000000..169c5c581912
--- /dev/null
+++ b/dev-python/pytest/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pytest
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.1 2010/12/13 13:30:30 arfrever Exp $
+
+*pytest-2.0.0 (13 Dec 2010)
+
+ 13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pytest-2.0.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/dev-python/pytest/metadata.xml b/dev-python/pytest/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/pytest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pytest/pytest-2.0.0.ebuild b/dev-python/pytest/pytest-2.0.0.ebuild
new file mode 100644
index 000000000000..23d78df302de
--- /dev/null
+++ b/dev-python/pytest/pytest-2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.0.ebuild,v 1.1 2010/12/13 13:30:30 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.0"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+}