summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-07 06:36:53 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-07 06:36:53 +0000
commit86ab48583623abc6fe912842daf17bf549a5086d (patch)
treef6230f2b9b1174596a0dab4262807fff41d074a4 /dev-python
parentFix building for hppa. (diff)
downloadgentoo-2-86ab48583623abc6fe912842daf17bf549a5086d.tar.gz
gentoo-2-86ab48583623abc6fe912842daf17bf549a5086d.tar.bz2
gentoo-2-86ab48583623abc6fe912842daf17bf549a5086d.zip
bump; restrict test phase due to massive failure rate, issue @ upstream of prior version extended informing of the increase, rm stray line form prior version
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mantissa/ChangeLog10
-rw-r--r--dev-python/mantissa/mantissa-0.8.0.ebuild3
-rw-r--r--dev-python/mantissa/mantissa-0.8.1.ebuild53
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-python/mantissa/ChangeLog b/dev-python/mantissa/ChangeLog
index 7be7e1c4750e..786b18c38757 100644
--- a/dev-python/mantissa/ChangeLog
+++ b/dev-python/mantissa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/mantissa
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.26 2015/07/20 04:30:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.27 2015/08/07 06:36:53 idella4 Exp $
+
+*mantissa-0.8.1 (07 Aug 2015)
+
+ 07 Aug 2015; Ian Delaney <idella4@gentoo.org> +mantissa-0.8.1.ebuild,
+ mantissa-0.8.0.ebuild:
+ bump; restrict test phase due to massive failure rate, issue @ upstream of
+ prior version extended informing of the increase, rm stray line form prior
+ version
20 Jul 2015; Ian Delaney <idella4@gentoo.org> mantissa-0.8.0.ebuild:
Update to msg via einfo in test phase re fixes to failures
diff --git a/dev-python/mantissa/mantissa-0.8.0.ebuild b/dev-python/mantissa/mantissa-0.8.0.ebuild
index 583bacb09145..a9eb84b41ca1 100644
--- a/dev-python/mantissa/mantissa-0.8.0.ebuild
+++ b/dev-python/mantissa/mantissa-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild,v 1.2 2015/07/20 04:30:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild,v 1.3 2015/08/07 06:36:53 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -39,7 +39,6 @@ python_test() {
einfo "A folder with required modules are absent form the source"
einfo "All are expected to be fixed in a next release consequent to the bug"
einfo "filed upstream, now expected very soon"; einfo ""
- die "dud"
trial xmantissa || die "tests failed with ${EPYTHON}"
}
diff --git a/dev-python/mantissa/mantissa-0.8.1.ebuild b/dev-python/mantissa/mantissa-0.8.1.ebuild
new file mode 100644
index 000000000000..25927a26c107
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.1.ebuild,v 1.1 2015/08/07 06:36:53 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="https://github.com/twisted/mantissa"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# https://github.com/twisted/mantissa/issues/27
+# Source still missing a folder 'doc' that has required modules and
+# the fail / error rate is far higher then in 0.8.0
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_test() {
+ # https://github.com/twisted/mantissa/issues/27
+
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}