summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-11 11:56:23 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-11 11:56:23 +0000
commit892f4b4c0d25a7878e2c84a00db1fe1b51e1b2b7 (patch)
tree391ef116c365626a7c26470d0d81ae08f8210984 /dev-python
parentFix function names. (diff)
downloadgentoo-2-892f4b4c0d25a7878e2c84a00db1fe1b51e1b2b7.tar.gz
gentoo-2-892f4b4c0d25a7878e2c84a00db1fe1b51e1b2b7.tar.bz2
gentoo-2-892f4b4c0d25a7878e2c84a00db1fe1b51e1b2b7.zip
Migrate to distutils-r1. Disable broken tests.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-memcached/ChangeLog8
-rw-r--r--dev-python/python-memcached/python-memcached-1.53-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/python-memcached/ChangeLog b/dev-python/python-memcached/ChangeLog
index 4e698fa260f6..e5d84cea22f7 100644
--- a/dev-python/python-memcached/ChangeLog
+++ b/dev-python/python-memcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-memcached
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.28 2013/07/08 06:19:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/ChangeLog,v 1.29 2013/08/11 11:56:23 mgorny Exp $
+
+*python-memcached-1.53-r1 (11 Aug 2013)
+
+ 11 Aug 2013; Michał Górny <mgorny@gentoo.org>
+ +python-memcached-1.53-r1.ebuild:
+ Migrate to distutils-r1. Disable broken tests.
*python-memcached-1.53 (08 Jul 2013)
diff --git a/dev-python/python-memcached/python-memcached-1.53-r1.ebuild b/dev-python/python-memcached/python-memcached-1.53-r1.ebuild
new file mode 100644
index 000000000000..b2a5678df519
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.53-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-memcached/python-memcached-1.53-r1.ebuild,v 1.1 2013/08/11 11:56:23 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ http://pypi.python.org/pypi/python-memcached"
+SRC_URI="ftp://ftp.tummy.com/pub/python-memcached/old-releases/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( net-misc/memcached )"
+RDEPEND=""
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}