summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-06-18 20:02:13 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-06-18 20:02:13 +0000
commit932b1610213d32cfa3e7adc36e8dedded9c3af26 (patch)
tree12db52e43db18bb03ca6426010e43e7320655d29 /dev-python
parentAdding ~x86 keyword, closes bug #274635 (diff)
downloadgentoo-2-932b1610213d32cfa3e7adc36e8dedded9c3af26.tar.gz
gentoo-2-932b1610213d32cfa3e7adc36e8dedded9c3af26.tar.bz2
gentoo-2-932b1610213d32cfa3e7adc36e8dedded9c3af26.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/ChangeLog8
-rw-r--r--dev-python/bpython/bpython-0.9.3.ebuild (renamed from dev-python/bpython/bpython-0.9.2.ebuild)12
-rw-r--r--dev-python/bpython/files/bpython-0.9.2.patch47
-rw-r--r--dev-python/bpython/metadata.xml4
4 files changed, 13 insertions, 58 deletions
diff --git a/dev-python/bpython/ChangeLog b/dev-python/bpython/ChangeLog
index d30bc2cde30e..a6f5e37f9786 100644
--- a/dev-python/bpython/ChangeLog
+++ b/dev-python/bpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/bpython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.6 2009/06/11 20:56:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.7 2009/06/18 20:02:13 grozin Exp $
+
+*bpython-0.9.3 (18 Jun 2009)
+
+ 18 Jun 2009; Andrey Grozin <grozin@gentoo.org> -bpython-0.9.2.ebuild,
+ -files/bpython-0.9.2.patch, +bpython-0.9.3.ebuild, metadata.xml:
+ Version bump
11 Jun 2009; Markus Meier <maekke@gentoo.org> bpython-0.9.2.ebuild:
add ~amd64, bug #273015
diff --git a/dev-python/bpython/bpython-0.9.2.ebuild b/dev-python/bpython/bpython-0.9.3.ebuild
index dbfa5fc2f56a..36bbdb3d04e2 100644
--- a/dev-python/bpython/bpython-0.9.2.ebuild
+++ b/dev-python/bpython/bpython-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.2.ebuild,v 1.5 2009/06/11 20:56:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.3.ebuild,v 1.1 2009/06/18 20:02:13 grozin Exp $
EAPI=2
PYTHON_USE_WITH=ncurses
@@ -15,11 +15,5 @@ IUSE=""
DEPEND="dev-python/setuptools"
# setuptools is needed at runtime for the wrapper script
RDEPEND="${DEPEND}
- dev-python/pygments
- dev-python/pyparsing"
-DOCS="sample.ini"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}"/${P}.patch
-}
+ dev-python/pygments"
+DOCS="sample.ini sample.theme light.theme"
diff --git a/dev-python/bpython/files/bpython-0.9.2.patch b/dev-python/bpython/files/bpython-0.9.2.patch
deleted file mode 100644
index 478858a0bb55..000000000000
--- a/dev-python/bpython/files/bpython-0.9.2.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Index: bpython-0.9.2/bpython/cli.py
-===================================================================
---- bpython-0.9.2.orig/bpython/cli.py
-+++ bpython-0.9.2/bpython/cli.py
-@@ -55,6 +55,7 @@ from ConfigParser import ConfigParser, N
- from pygments import format
- from pygments.lexers import PythonLexer
- from pygments.token import Token
-+import bpython.formatter
- from bpython.formatter import BPythonFormatter
- from itertools import chain
-
-@@ -1828,6 +1829,7 @@ def loadini(configfile):
- OPTS.tab_length = config.safeget('general', 'tab_length', 4)
- OPTS.auto_display_list = config.safeget('general', 'auto_display_list', True)
- OPTS.syntax = config.safeget('general', 'syntax', True)
-+ OPTS.light = config.safeget('general', 'light', False)
- OPTS.arg_spec = config.safeget('general', 'arg_spec', True)
- OPTS.hist_file = config.safeget('general', 'hist_file', '~/.pythonhist')
- OPTS.hist_length = config.safeget('general', 'hist_length', 100)
-@@ -1920,8 +1922,12 @@ def main(args=None):
- path = os.path.expanduser('~/.bpythonrc') # migrating old configuration file
- if os.path.isfile(path):
- migrate_rc(path)
-+
- loadini(options.config)
-
-+ if OPTS.light:
-+ bpython.formatter.f_strings = bpython.formatter.f_strings_light
-+
- try:
- o = curses.wrapper(main_curses)
- except:
-Index: bpython-0.9.2/sample.ini
-===================================================================
---- bpython-0.9.2.orig/sample.ini
-+++ bpython-0.9.2/sample.ini
-@@ -14,6 +14,9 @@ auto_display_list = True
- # Syntax highlighting as you type (default: True).
- syntax = True
-
-+# Light background (default: False).
-+light = False
-+
- # Display the arg spec (list of arguments) for callables,
- # when possible (default: True).
- arg_spec = True
diff --git a/dev-python/bpython/metadata.xml b/dev-python/bpython/metadata.xml
index 14f0b952b05f..60e38ca23306 100644
--- a/dev-python/bpython/metadata.xml
+++ b/dev-python/bpython/metadata.xml
@@ -6,5 +6,7 @@
<email>grozin@gentoo.org</email>
<name>Andrey Grozin</name>
</maintainer>
- <longdescription>Curses interface to python</longdescription>
+ <longdescription>Syntax highlighting and autocompletion
+ for the python interpreter
+ </longdescription>
</pkgmetadata>