summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 02:46:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 02:46:35 +0000
commit95caacf4664d0bd36371d1a930c78da7a7e4d4a5 (patch)
tree1879284b92ffc13925b0763cd88cb691d7547908 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-95caacf4664d0bd36371d1a930c78da7a7e4d4a5.tar.gz
gentoo-2-95caacf4664d0bd36371d1a930c78da7a7e4d4a5.tar.bz2
gentoo-2-95caacf4664d0bd36371d1a930c78da7a7e4d4a5.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14920-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/epsilon/ChangeLog8
-rw-r--r--dev-python/epsilon/epsilon-0.5.11.ebuild57
-rw-r--r--dev-python/epsilon/epsilon-0.6.0.ebuild63
3 files changed, 70 insertions, 58 deletions
diff --git a/dev-python/epsilon/ChangeLog b/dev-python/epsilon/ChangeLog
index 7ea701d7ebd8..38a0a4a82cf8 100644
--- a/dev-python/epsilon/ChangeLog
+++ b/dev-python/epsilon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/epsilon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.15 2009/05/17 01:18:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.16 2009/11/30 02:46:35 arfrever Exp $
+
+*epsilon-0.6.0 (30 Nov 2009)
+
+ 30 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -epsilon-0.5.11.ebuild, +epsilon-0.6.0.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*epsilon-0.5.12 (17 May 2009)
diff --git a/dev-python/epsilon/epsilon-0.5.11.ebuild b/dev-python/epsilon/epsilon-0.5.11.ebuild
deleted file mode 100644
index a64a53e14430..000000000000
--- a/dev-python/epsilon/epsilon-0.5.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.11.ebuild,v 1.5 2009/05/17 01:18:26 arfrever Exp $
-
-EAPI="2"
-inherit twisted distutils
-
-DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class."
-HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon"
-SRC_URI="http://divmod.org/trac/attachment/wiki/SoftwareReleases/Epsilon-${PV}.tar.gz?format=raw -> Epsilon-${PV}.tar.gz"
-#SRC_URI="mirror://gentoo/Epsilon-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~ia64 ~ppc64 ~x86 ~amd64"
-IUSE=""
-
-DEPEND=">=dev-lang/python-2.4
- >=dev-python/twisted-2.4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/Epsilon-${PV}"
-
-DOCS="NAME.txt NEWS.txt"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Rename to avoid file-collisions
- mv bin/benchmark bin/epsilon-benchmark
- sed -i \
- -e "s#bin/benchmark#bin/epsilon-benchmark#" \
- setup.py || die "sed failed"
- # otherwise we get sandbox violations as it wants to update
- # the plugin cache
- epatch "${FILESDIR}/epsilon_plugincache_portagesandbox.patch"
-}
-
-src_compile() {
- # skip this, or epsilon will install the temporary "build" dir
- true
-}
-
-src_test() {
- # release tests needs DivmodCombinator
- rm epsilon/test/test_release.py*
- PYTHONPATH=. trial epsilon || die "tests failed"
-}
-
-pkg_postrm() {
- twisted_pkg_postrm
-}
-
-pkg_postinst() {
- twisted_pkg_postinst
-}
diff --git a/dev-python/epsilon/epsilon-0.6.0.ebuild b/dev-python/epsilon/epsilon-0.6.0.ebuild
new file mode 100644
index 000000000000..d097ad3ae4d4
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.6.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.6.0.ebuild,v 1.1 2009/11/30 02:46:35 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+# setup.py uses epsilon.setuphelper.autosetup(), which tries to use
+# build-${PYTHON_ABI} directories as packages.
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit distutils twisted
+
+MY_PN="Epsilon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon http://pypi.python.org/pypi/Epsilon"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/twisted-2.4"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="NAME.txt NEWS.txt"
+
+src_prepare() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+ # otherwise we get sandbox violations as it wants to update
+ # the plugin cache
+ epatch "${FILESDIR}/epsilon_plugincache_portagesandbox.patch"
+
+ python_copy_sources
+}
+
+src_test() {
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py*
+
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" trial epsilon
+ }
+ python_execute_function testing
+}
+
+pkg_postrm() {
+ twisted_pkg_postrm
+}
+
+pkg_postinst() {
+ twisted_pkg_postinst
+}