summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-01 13:52:14 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-01 13:52:14 +0000
commit99a00a9741f1df9a5116956c1eba04c29092d6e4 (patch)
treeff2b93c309059c2b74b7c8563042b3f0d6f73e2b /dev-python
parentversion bump (diff)
downloadgentoo-2-99a00a9741f1df9a5116956c1eba04c29092d6e4.tar.gz
gentoo-2-99a00a9741f1df9a5116956c1eba04c29092d6e4.tar.bz2
gentoo-2-99a00a9741f1df9a5116956c1eba04c29092d6e4.zip
dev-python/argcomplete: Version Bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/argcomplete/ChangeLog7
-rw-r--r--dev-python/argcomplete/argcomplete-0.8.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/argcomplete/ChangeLog b/dev-python/argcomplete/ChangeLog
index b6b3a457825b..b64664458e25 100644
--- a/dev-python/argcomplete/ChangeLog
+++ b/dev-python/argcomplete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/argcomplete
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/ChangeLog,v 1.6 2014/10/04 04:56:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/ChangeLog,v 1.7 2014/12/01 13:52:14 jlec Exp $
+
+*argcomplete-0.8.1 (01 Dec 2014)
+
+ 01 Dec 2014; Justin Lecher <jlec@gentoo.org> +argcomplete-0.8.1.ebuild:
+ Version Bump
*argcomplete-0.6.5-r1 (04 Oct 2014)
diff --git a/dev-python/argcomplete/argcomplete-0.8.1.ebuild b/dev-python/argcomplete/argcomplete-0.8.1.ebuild
new file mode 100644
index 000000000000..619aae089847
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argcomplete/argcomplete-0.8.1.ebuild,v 1.1 2014/12/01 13:52:14 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # purge test folder to avoid file collisions
+ sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} test/test.py || die
+}
+
+python_install_all() {
+ sed \
+ -e "/complete /d" \
+ -i argcomplete/bash_completion.d/python-argcomplete.sh || die
+ insinto $(get_bashhelpersdir)
+ doins argcomplete/bash_completion.d/python-argcomplete.sh
+ distutils-r1_python_install_all
+}