summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-21 01:43:35 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-21 01:43:35 +0000
commita0b93bb8de2e3cec15eb8abc5a057e9cb786809b (patch)
tree3220bb4e3c3573b17696e8c1a3bdc1565557716a /dev-python
parentVersion bump. (diff)
downloadgentoo-2-a0b93bb8de2e3cec15eb8abc5a057e9cb786809b.tar.gz
gentoo-2-a0b93bb8de2e3cec15eb8abc5a057e9cb786809b.tar.bz2
gentoo-2-a0b93bb8de2e3cec15eb8abc5a057e9cb786809b.zip
revbump; add py3.3 support, update to test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbr/ChangeLog10
-rw-r--r--dev-python/pbr/pbr-0.5.23-r1.ebuild61
-rw-r--r--dev-python/pbr/pbr-0.5.23.ebuild4
3 files changed, 71 insertions, 4 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
index c6c8a6a3bbf8..7d2f4fcb940a 100644
--- a/dev-python/pbr/ChangeLog
+++ b/dev-python/pbr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pbr
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.8 2013/12/13 21:37:57 prometheanfire Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.9 2014/01/21 01:43:35 idella4 Exp $
+
+*pbr-0.5.23-r1 (21 Jan 2014)
+
+ 21 Jan 2014; Ian Delaney <idella4@gentoo.org> +pbr-0.5.23-r1.ebuild,
+ pbr-0.5.23.ebuild:
+ revbump; add py3.3 support, update to test phase
13 Dec 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.23.ebuild:
more missing test deps
diff --git a/dev-python/pbr/pbr-0.5.23-r1.ebuild b/dev-python/pbr/pbr-0.5.23-r1.ebuild
new file mode 100644
index 000000000000..d8061e2d69e7
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.23-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23-r1.ebuild,v 1.1 2014/01/21 01:43:35 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ <dev-python/testresources-0.3[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ <dev-python/testscenarios-0.5[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ # These tests pass run within the source and don't represent failures but rather
+ # work outside the sandbox constraints
+ sed -e s':test_changelog:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+
+ sed -e s':test_authors:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_global_setup_hooks:_&:' -i pbr/tests/test_hooks.py \
+ -e s':test_custom_commands_known:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -i pbr/tests/test_hooks.py
+ sed -e s':test_setup_py_keywords:_&:' \
+ -e s':test_sdist_git_extra_file:_&:' \
+ -e s':test_sdist_extra_file:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_custom_build_py_command:_&:' \
+ -i pbr/tests/test_commands.py || die
+
+ testr init
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}
diff --git a/dev-python/pbr/pbr-0.5.23.ebuild b/dev-python/pbr/pbr-0.5.23.ebuild
index 2398e3ab82f8..ec582798a9b7 100644
--- a/dev-python/pbr/pbr-0.5.23.ebuild
+++ b/dev-python/pbr/pbr-0.5.23.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23.ebuild,v 1.3 2013/12/13 21:37:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23.ebuild,v 1.4 2014/01/21 01:43:35 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )