summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2004-09-06 11:09:23 +0000
committerChristian Andreetta <satya@gentoo.org>2004-09-06 11:09:23 +0000
commita25f9bda0ce4361a7312eaf9a23449b1c3465c52 (patch)
tree498c412c12705f7830be62325e0431a87d5b4545 /dev-python
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-a25f9bda0ce4361a7312eaf9a23449b1c3465c52.tar.gz
gentoo-2-a25f9bda0ce4361a7312eaf9a23449b1c3465c52.tar.bz2
gentoo-2-a25f9bda0ce4361a7312eaf9a23449b1c3465c52.zip
some install paths fixes (apache2, logs, /var/lib)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/skunkweb/ChangeLog8
-rw-r--r--dev-python/skunkweb/Manifest2
-rw-r--r--dev-python/skunkweb/files/digest-skunkweb-3.4_beta5-r11
-rw-r--r--dev-python/skunkweb/skunkweb-3.4_beta5-r1.ebuild85
4 files changed, 95 insertions, 1 deletions
diff --git a/dev-python/skunkweb/ChangeLog b/dev-python/skunkweb/ChangeLog
index 203be710f703..a0f2350a5158 100644
--- a/dev-python/skunkweb/ChangeLog
+++ b/dev-python/skunkweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/skunkweb
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/skunkweb/ChangeLog,v 1.8 2004/09/03 13:23:19 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/skunkweb/ChangeLog,v 1.9 2004/09/06 11:09:23 satya Exp $
+
+*skunkweb-3.4_beta5-r1 (06 Sep 2004)
+
+ 06 Sep 2004; Christian Andreetta <satya@gentoo.org>
+ +skunkweb-3.4_beta5-r1.ebuild:
+ some install paths fixes (apache2, logs, /var/lib)
03 Sep 2004; Christian Andreetta <satya@gentoo.org> metadata.xml,
+files/skunkweb-init, skunkweb-3.4_beta5.ebuild:
diff --git a/dev-python/skunkweb/Manifest b/dev-python/skunkweb/Manifest
index 7cf5c49dc0e5..bee589fdee2b 100644
--- a/dev-python/skunkweb/Manifest
+++ b/dev-python/skunkweb/Manifest
@@ -1,5 +1,7 @@
+MD5 fa20ac5a06dfcec08e4f22e55490b8ad skunkweb-3.4_beta5-r1.ebuild 2608
MD5 d69e6c1d60d2ae51ff9802f479839002 ChangeLog 1170
MD5 ce3f2bc35dd35ff24c757ab6f807ddae metadata.xml 488
MD5 545fd5a4bbb9939e5c9100b9e8797163 skunkweb-3.4_beta5.ebuild 2232
MD5 04c336f15c6758c2a02eb4187e8b2600 files/skunkweb-init 647
MD5 33defac2f69099260dac7f1a043b2643 files/digest-skunkweb-3.4_beta5 67
+MD5 33defac2f69099260dac7f1a043b2643 files/digest-skunkweb-3.4_beta5-r1 67
diff --git a/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5-r1 b/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5-r1
new file mode 100644
index 000000000000..3a7dc4213de5
--- /dev/null
+++ b/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5-r1
@@ -0,0 +1 @@
+MD5 74fc5c98c036d0453ede0c9aaa51f4b0 skunkweb-3.4b5.tar.gz 1952771
diff --git a/dev-python/skunkweb/skunkweb-3.4_beta5-r1.ebuild b/dev-python/skunkweb/skunkweb-3.4_beta5-r1.ebuild
new file mode 100644
index 000000000000..ef9a038f2c3e
--- /dev/null
+++ b/dev-python/skunkweb/skunkweb-3.4_beta5-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/skunkweb/skunkweb-3.4_beta5-r1.ebuild,v 1.1 2004/09/06 11:09:23 satya Exp $
+
+inherit eutils
+
+DESCRIPTION="robust Python web application server"
+HOMEPAGE="http://skunkweb.sourceforge.net/"
+#NEWP=`echo ${P} | sed -e 's|_beta|b|'`
+NEWP=${P/_beta/b}
+S=${WORKDIR}/${NEWP}
+SRC_URI="mirror://sourceforge/skunkweb/${NEWP}.tar.gz"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="apache1 apache2 doc"
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.4
+ apache2? ( >=net-www/apache-2.0.47 )
+ !apache2? ( apache1? ( <=net-www/apache-2 ) )"
+
+pkg_setup() {
+ enewgroup skunkweb
+ enewuser skunkweb -1 /bin/false /usr/share/skunkweb skunkweb
+}
+
+src_compile() {
+ local myconf
+ if use apache2; then
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs2"
+ else
+ if use apache1; then
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ else
+ myconf="${myconf} --without-mod_skunkweb"
+ fi
+ fi
+ econf \
+ --with-user=skunkweb \
+ --with-group=skunkweb \
+ --localstatedir=/var/lib/skunkweb \
+ --bindir=/usr/bin \
+ --libdir=/usr/lib/skunkweb \
+ --sysconfdir=/etc/skunkweb \
+ --prefix=/usr/share/skunkweb \
+ --with-cache=/var/lib/skunkweb/cache \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-logdir=/var/log/skunkweb \
+ --with-python=/usr/bin/python \
+ ${myconf} || die "configure failed"
+
+ emake || die
+}
+
+src_install() {
+ INSTALLING="yes"
+ make DESTDIR=${D} APXSFLAGS="-c" install || die
+ if use apache2; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe SkunkWeb/mod_skunkweb/.libs/mod_skunkweb.so
+ insinto /etc/apache2/conf/modules.d
+ newins SkunkWeb/mod_skunkweb/httpd_conf.stub mod_skunkweb.conf
+ else
+ if use apache1; then
+ exeinto /usr/lib/apache-extramodules
+ doexe SkunkWeb/mod_skunkweb/mod_skunkweb.so
+ insinto /etc/apache/conf/addon-modules
+ newins SkunkWeb/mod_skunkweb/httpd_conf.stub mod_skunkweb.conf
+ fi
+ fi
+ # dirs --------------------------------------------------------------
+ mkdir -p ${D}/var/{lib,log}/${PN}
+ chown skunkweb:skunkweb ${D}/var/{lib,log}/${PN}
+ mkdir -p ${D}/var/lib/${PN}/run
+ # init --------------------------------------------------------------
+ exeinto /etc/init.d; newexe ${FILESDIR}/skunkweb-init skunkweb
+ # docs --------------------------------------------------------------
+ dodoc README ChangeLog NEWS HACKING ACKS INSTALL
+ if use doc; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ #cp docs/paper-letter/*.pdf ${D}/usr/share/doc/${PF}
+ cp docs/paper-a4/*.pdf ${D}/usr/share/doc/${PF}
+ fi
+}